summaryrefslogtreecommitdiffstats
path: root/c/make/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'c/make/configure.ac')
-rw-r--r--c/make/configure.ac53
1 files changed, 53 insertions, 0 deletions
diff --git a/c/make/configure.ac b/c/make/configure.ac
new file mode 100644
index 0000000000..eda474daf7
--- /dev/null
+++ b/c/make/configure.ac
@@ -0,0 +1,53 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+##
+## This script configures the configuration files below c/make/
+##
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([target.cfg.in])
+RTEMS_TOP(../..)
+AC_CONFIG_AUX_DIR(../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-make,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_MULTIPROCESSING
+RTEMS_ENABLE_POSIX
+RTEMS_ENABLE_ITRON
+RTEMS_ENABLE_NETWORKING
+RTEMS_ENABLE_RDBG
+RTEMS_ENABLE_INLINES
+RTEMS_ENABLE_CXX
+RTEMS_ENABLE_GCC28
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+RTEMS_PROG_CC_FOR_TARGET
+
+## check for g++
+if test "$RTEMS_HAS_CPLUSPLUS" = "yes"; then
+ RTEMS_PROG_CXX_FOR_TARGET
+fi
+
+RTEMS_CANONICALIZE_TOOLS
+
+AC_SUBST(RTEMS_HAS_POSIX)
+AC_SUBST(RTEMS_HOST)
+AC_SUBST(RTEMS_HAS_CPLUSPLUS)
+AC_SUBST(RTEMS_USE_GCC272)
+AC_SUBST(RTEMS_CPU)
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+target.cfg
+])
+AC_OUTPUT