summaryrefslogtreecommitdiffstats
path: root/c/build-tools/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/build-tools/src/Makefile.am')
-rw-r--r--c/build-tools/src/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/c/build-tools/src/Makefile.am b/c/build-tools/src/Makefile.am
new file mode 100644
index 0000000000..2a00eb73b5
--- /dev/null
+++ b/c/build-tools/src/Makefile.am
@@ -0,0 +1,22 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS=cklength eolstrip packhex unhex
+
+cklength_SOURCES = cklength.c
+eolstrip_SOURCES = eolstrip.c
+packhex_SOURCES = packhex.c
+unhex_SOURCES = unhex.c
+
+#
+# HACK: install to the build-tree
+#
+install-exec-local: $(bin_PROGRAMS)
+ $(mkinstalldirs) $(PROJECT_ROOT)/${RTEMS_BSP}/build-tools
+ $(INSTALL_PROGRAM) $(bin_PROGRAMS) \
+ $(PROJECT_ROOT)/${RTEMS_BSP}/build-tools
+
+preinstall: install-exec-local