summaryrefslogtreecommitdiffstats
path: root/c/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/Makefile.am')
-rw-r--r--c/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/c/Makefile.am b/c/Makefile.am
index 3f62704966..2566e09e1c 100644
--- a/c/Makefile.am
+++ b/c/Makefile.am
@@ -2,13 +2,12 @@
# $Id$
#
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
## NOTE: This Makefile.am is rather fragile to the value of RTEMS_BSP
## Esp. make clean and make distclean have unwanted side-effects
## if RTEMS_BSP is not properly set up.
-AUTOMAKE_OPTIONS = foreign 1.4
-ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
-
RTEMS_BSP = $(RTEMS_BSP_LIST)
## The '.' in SUBDIRS ensures that local make-targets (xxx-am) will be
## triggered before $(RTEMS_BSP_LIST) subdirectories are made.
@@ -16,7 +15,6 @@ SUBDIRS= \
. \
$(RTEMS_BSP)
-
## Use @RTEMS_BSP_LIST@ here, using $(RTEMS_BSP_LIST) would trigger
## this rule for invalid BSPs
@RTEMS_BSP_LIST@: src/configure