summaryrefslogtreecommitdiffstats
path: root/c/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'c/Makefile.am')
-rw-r--r--c/Makefile.am13
1 files changed, 0 insertions, 13 deletions
diff --git a/c/Makefile.am b/c/Makefile.am
index 5429470cbc..ac5c94191c 100644
--- a/c/Makefile.am
+++ b/c/Makefile.am
@@ -13,18 +13,6 @@ RTEMS_BSP = $(RTEMS_BSP_LIST)
## triggered before $(RTEMS_BSP_LIST) subdirectories are made.
SUBDIRS = . $(RTEMS_BSP)
-## Use @RTEMS_BSP_LIST@ here, using $(RTEMS_BSP_LIST) would trigger
-## this rule for invalid BSPs
-@RTEMS_BSP_LIST@: src/configure
- @set fnord $(MAKEFLAGS); amf=$$2; \
- test -n "${RTEMS_BSP}" && for i in ${RTEMS_BSP}; do \
- echo "Configuring RTEMS_BSP=$$i"; \
- $(mkdir_p) $$i; \
- ( cd $$i && \
- CONFIG_SHELL=$(SHELL) RTEMS_BSP=$$i $(rtems_bsp_configure) ) \
- || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
- done
-
## Let all RTEMS' make targets depend on ${RTEMS_BSP}
all-local: ${RTEMS_BSP}
preinstall-am: ${RTEMS_BSP}
@@ -35,7 +23,6 @@ EXTRA_DIST = ACKNOWLEDGEMENTS
EXTRA_DIST += TOOL_TARGETS
DIST_SUBDIRS = ${RTEMS_BSP}
-## -------------------------------------------------------
include $(top_srcdir)/../automake/host.am
include $(top_srcdir)/../automake/subdirs.am