summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 20 insertions, 22 deletions
diff --git a/Makefile.am b/Makefile.am
index c13e8e2a09..d91ad10096 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,31 +7,29 @@
##
AUTOMAKE_OPTIONS = foreign 1.4
-ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/macros
-SUBDIRS = doc make tools @TARGET_SUBDIRS@
+SUBDIRS = doc make tools $(HOST_SUBDIRS) $(TARGET_SUBDIRS)
AUTOMAKE_FILES = automake/compile.am automake/host.am automake/lib.am \
- automake/local.am automake/multilib.am automake/subdirs.am
-
-ACLOCAL_FILES += aclocal/ar-s.m4 aclocal/bsp-alias.m4 \
- aclocal/canonical-host.m4 aclocal/canonical-target-name.m4 \
- aclocal/canonicalize-tools.m4 aclocal/check-bsps.m4 \
- aclocal/check-bsp-cache.m4 aclocal/check-cpu.m4 aclocal/check-cxx.m4 \
- aclocal/check-itron.m4 aclocal/check-multiprocessing.m4 \
- aclocal/check-networking.m4 aclocal/check-newlib.m4 \
- aclocal/check-posix.m4 aclocal/check-rdbg.m4 aclocal/enable-bare.m4 \
- aclocal/enable-cxx.m4 aclocal/enable-gcc28.m4 \
- aclocal/enable-inlines.m4 aclocal/enable-itron.m4 \
- aclocal/enable-libcdir.m4 aclocal/enable-multiprocessing.m4 \
- aclocal/enable-networking.m4 aclocal/enable-posix.m4 \
- aclocal/enable-rdbg.m4 aclocal/enable-rtemsbsp.m4 \
- aclocal/enable-tests.m4 aclocal/gcc-pipe.m4 aclocal/gcc-specs.m4 \
- aclocal/i386-gas-code16.m4 aclocal/path-ksh.m4 aclocal/path-perl.m4 \
- aclocal/prog-cc.m4 aclocal/prog-cxx.m4 aclocal/project-root.m4 \
- aclocal/rtems-top.m4 aclocal/sysv-ipc.m4 aclocal/target.m4 \
- aclocal/tool-paths.m4 aclocal/tool-prefix.m4 aclocal/multilib.m4 \
- aclocal/rtems-debug.m4 aclocal/rtems-test-no-pause.m4
+ automake/local.am automake/multilib.am automake/subdirs.am
+
+ACLOCAL_FILES += macros/bsp-alias.m4 macros/canonical-host.m4 \
+ macros/canonical-target-name.m4 macros/canonicalize-tools.m4 \
+ macros/check-bsp-cache.m4 macros/check-bsps.m4 macros/check-cpu.m4 \
+ macros/check-cxx.m4 macros/check-itron.m4 \
+ macros/check-multiprocessing.m4 macros/check-networking.m4 \
+ macros/check-newlib.m4 macros/check-posix.m4 macros/check-rdbg.m4 \
+ macros/enable-bare.m4 macros/enable-cxx.m4 macros/enable-gcc28.m4 \
+ macros/enable-inlines.m4 macros/enable-itron.m4 macros/enable-libcdir.m4 \
+ macros/enable-multiprocessing.m4 macros/enable-networking.m4 \
+ macros/enable-posix.m4 macros/enable-rdbg.m4 macros/enable-rtemsbsp.m4 \
+ macros/enable-tests.m4 macros/gcc-pipe.m4 macros/gcc-specs.m4 \
+ macros/i386-gas-code16.m4 macros/multilib.m4 macros/path-ksh.m4 \
+ macros/path-perl.m4 macros/prog-cc.m4 macros/prog-cxx.m4 \
+ macros/project-root.m4 macros/rtems-debug.m4 \
+ macros/rtems-test-no-pause.m4 macros/rtems-top.m4 macros/sysv-ipc.m4 \
+ macros/target.m4 macros/tool-paths.m4
noinst_SCRIPTS = bootstrap