summaryrefslogtreecommitdiffstats
path: root/tools/schedsim/shell/shared/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-12-17 14:49:40 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-12-17 14:49:40 +0000
commitabff6d226a55f3453b085c0d920e02973b971743 (patch)
treef5f15ca1e598f61d5ce78a01ce333e83d7c2f8af /tools/schedsim/shell/shared/Makefile.am
parent2010-12-16 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-abff6d226a55f3453b085c0d920e02973b971743.tar.bz2
2010-12-17 Joel Sherrill <joel.sherrill@oarcorp.com>
Jennifer Averett <jennifer.averett@oarcorp.com> Add RTEMS Scheduler Simulator. This is the shell scripting portion. * .cvsignore, ChangeLog, Makefile.am, schedsim_priority/.cvsignore, schedsim_priority/Makefile.am, schedsim_priority/config.c, schedsim_priority/printheir_executing.c, schedsim_priority/schedsim.cc, schedsim_priority/wrap_thread_dispatch.c, scripts/script01, scripts/script02, scripts/script03, scripts/script04, scripts/script05, scripts/script06, shared/.cvsignore, shared/Makefile.am, shared/commands.c, shared/getopt.c, shared/lookup_semaphore.c, shared/lookup_task.c, shared/main_clocktick.c, shared/main_echo.c, shared/main_executing.c, shared/main_heir.c, shared/main_help.c, shared/main_rtemsinit.c, shared/main_semcreate.c, shared/main_semdelete.c, shared/main_semflush.c, shared/main_semobtain.c, shared/main_semrelease.c, shared/main_taskcreate.c, shared/main_taskdelete.c, shared/main_taskmode.c, shared/main_taskpriority.c, shared/main_taskresume.c, shared/main_tasksuspend.c, shared/main_taskwakeafter.c, shared/schedsim_shell.h, shared/shell_cmdset.c, shared/shell_makeargs.c, shared/include/shell.h, shared/include/newlib/_ansi.h, shared/include/newlib/getopt.h: New files.
Diffstat (limited to 'tools/schedsim/shell/shared/Makefile.am')
-rw-r--r--tools/schedsim/shell/shared/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/tools/schedsim/shell/shared/Makefile.am b/tools/schedsim/shell/shared/Makefile.am
new file mode 100644
index 0000000000..cfa1f3a46a
--- /dev/null
+++ b/tools/schedsim/shell/shared/Makefile.am
@@ -0,0 +1,61 @@
+##
+## $Id$
+##
+
+ACLOCAL_AMFLAGS = -I ../../../aclocal
+
+lib_LIBRARIES = libschedsim.a
+
+cpukitdir=$(srcdir)/../../../../cpukit
+libschedsim_a_CPPFLAGS = -D__RTEMS_VIOLATE_KERNEL_VISIBILITY__
+libschedsim_a_CPPFLAGS += -I$(srcdir)/sched_cpu
+libschedsim_a_CPPFLAGS += -I$(srcdir)/../../rtems
+libschedsim_a_CPPFLAGS += -I$(cpukitdir)/include
+libschedsim_a_CPPFLAGS += -I$(cpukitdir)/score/include
+libschedsim_a_CPPFLAGS += -I$(cpukitdir)/score/inline
+libschedsim_a_CPPFLAGS += -I$(cpukitdir)/rtems/include
+libschedsim_a_CPPFLAGS += -I$(cpukitdir)/rtems/inline
+libschedsim_a_CPPFLAGS += -I$(cpukitdir)/sapi/include
+libschedsim_a_CPPFLAGS += -I$(cpukitdir)/sapi/inline
+libschedsim_a_CPPFLAGS += -I$(cpukitdir)/libcsupport/include
+libschedsim_a_CPPFLAGS += -I$(cpukitdir)/libmisc/stringto
+libschedsim_a_CPPFLAGS += -I$(srcdir)/../../rtems/sched_cpu
+libschedsim_a_CPPFLAGS += -I$(srcdir)/include
+
+
+libschedsim_a_SOURCES = \
+ commands.c \
+ getopt.c \
+ lookup_semaphore.c \
+ lookup_task.c \
+ main_echo.c \
+ main_executing.c \
+ main_heir.c \
+ main_help.c \
+ main_rtemsinit.c \
+ main_clocktick.c \
+ main_semcreate.c \
+ main_semdelete.c \
+ main_semflush.c \
+ main_semobtain.c \
+ main_semrelease.c \
+ main_taskcreate.c \
+ main_taskdelete.c \
+ main_taskmode.c \
+ main_taskpriority.c \
+ main_taskresume.c \
+ main_tasksuspend.c \
+ main_taskwakeafter.c \
+ shell_cmdset.c \
+ shell_makeargs.c
+
+schedsim_shell_includedir = $(includedir)/schedsim
+schedsim_newlib_includedir = $(includedir)/schedsim/newlib
+
+schedsim_shell_include_HEADERS = include/shell.h schedsim_shell.h
+
+schedsim_newlib_include_HEADERS = \
+ include/newlib/getopt.h \
+ include/newlib/_ansi.h
+
+include $(top_srcdir)/../../automake/host.am