summaryrefslogtreecommitdiffstats
path: root/tools/schedsim/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-12-17 14:53:29 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-12-17 14:53:29 +0000
commit7accb652a7b0dc037301ea3f21e7c66d439b98c8 (patch)
tree5d4bea4143ac725de93f868a342d079a4807af82 /tools/schedsim/configure.ac
parent2010-12-17 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-7accb652a7b0dc037301ea3f21e7c66d439b98c8.tar.bz2
2010-12-17 Joel Sherrill <joel.sherrill@oarcorp.com>
Jennifer Averett <jennifer.averett@oarcorp.com> Add RTEMS Scheduler Simulator. This is the top level of the tree. * .cvsignore, ChangeLog, Makefile.am, configure.ac: New files.
Diffstat (limited to '')
-rw-r--r--tools/schedsim/configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/tools/schedsim/configure.ac b/tools/schedsim/configure.ac
new file mode 100644
index 0000000000..e4c3bb660b
--- /dev/null
+++ b/tools/schedsim/configure.ac
@@ -0,0 +1,32 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.60)
+AC_INIT([rtems-tools-schedsim],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
+AC_CONFIG_SRCDIR([rtems])
+RTEMS_TOP(../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE([no-define foreign 1.10])
+AM_MAINTAINER_MODE
+
+RTEMS_PATH_KSH
+
+AC_PROG_RANLIB
+AC_PROG_CC
+AC_PROG_CXX
+
+RTEMS_TOOLPATHS
+AC_SUBST(program_prefix)
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([
+Makefile
+rtems/Makefile
+shell/Makefile
+shell/shared/Makefile
+shell/schedsim_priority/Makefile
+])
+AC_OUTPUT