summaryrefslogtreecommitdiffstats
path: root/tools/cpu/unix/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-03-24 23:14:36 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-03-24 23:14:36 +0000
commit244ecd9fb87dec2aeed6fb97d37dd8a43f9be4cc (patch)
tree6bffdff113f276d1e2c74064582281d556305ff8 /tools/cpu/unix/Makefile.am
parent Fix based on bug report from Ralf Corsepius <corsepiu@faw.uni-ulm.de>: (diff)
downloadrtems-244ecd9fb87dec2aeed6fb97d37dd8a43f9be4cc.tar.bz2
These files were not added as part of a recent patch from
Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Diffstat (limited to '')
-rw-r--r--tools/cpu/unix/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/tools/cpu/unix/Makefile.am b/tools/cpu/unix/Makefile.am
new file mode 100644
index 0000000000..65147c0a2b
--- /dev/null
+++ b/tools/cpu/unix/Makefile.am
@@ -0,0 +1,26 @@
+#
+# $Id$
+#
+
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL = @ACLOCAL@ -I $(RTEMS_TOPdir)/aclocal
+
+noinst_PROGRAMS=gensize
+
+gensize_SOURCES=gensize.c
+
+# We use files that have not been installed yet.
+CPU_DIR=$(srcdir)/../../cpu/$(RTEMS_CPU)
+
+INCLUDES = \
+-I$(PROJECT_ROOT)/${RTEMS_BSP}/include \
+-I$(CPU_DIR)
+
+# HACK: install into the build-tree
+preinstall: install-exec-local
+
+install-exec-local: gensize
+ $(mkinstalldirs) $(PROJECT_ROOT)/${RTEMS_BSP}/bin
+ $(INSTALL_PROGRAM) gensize $(PROJECT_ROOT)/${RTEMS_BSP}/bin
+
+include $(top_srcdir)/../../../../../../automake/local.am