summaryrefslogtreecommitdiffstats
path: root/tools/cpu/nios2/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2006-08-09 21:05:32 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2006-08-09 21:05:32 +0000
commit037e16396df671074fca9e0348626b724d2c2960 (patch)
tree09dd6fa9a7d56dab4284ef1416fed604dc84965d /tools/cpu/nios2/Makefile.am
parent2006-08-09 Kolja Waschk <waschk@telos.de> (diff)
downloadrtems-037e16396df671074fca9e0348626b724d2c2960.tar.bz2
2006-08-09 Kolja Waschk <waschk@telos.de>
* configure.ac: New port to Altera NIOS II. * nios2/.cvsignore, nios2/Makefile.am, nios2/README, nios2/bridges.c, nios2/bridges.h, nios2/clocks.c, nios2/clocks.h, nios2/configure.ac, nios2/devices.c, nios2/devices.h, nios2/nios2gen.c, nios2/output.c, nios2/output.h, nios2/ptf.c, nios2/ptf.h: New files.
Diffstat (limited to '')
-rw-r--r--tools/cpu/nios2/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/cpu/nios2/Makefile.am b/tools/cpu/nios2/Makefile.am
new file mode 100644
index 0000000000..b71477af4b
--- /dev/null
+++ b/tools/cpu/nios2/Makefile.am
@@ -0,0 +1,23 @@
+##
+## $Id$
+##
+
+ACLOCAL_AMFLAGS = -I ../../../aclocal
+
+noinst_PROGRAMS = nios2gen
+
+nios2gen_SOURCES = nios2gen.c \
+ bridges.c bridges.h \
+ devices.c devices.h \
+ clocks.c clocks.h \
+ output.c output.h \
+ ptf.h ptf.c
+
+if HELP2MAN
+man_MANS = nios2gen.1
+
+nios2gen.1: nios2gen$(EXEEXT)
+ $(HELP2MAN) -N ./nios2gen >$@
+endif
+
+include $(top_srcdir)/../../../automake/host.am