summaryrefslogtreecommitdiffstats
path: root/testsuites/tools/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-12 18:47:00 +0000
commitd7aecdc8f866b978a4349b0e157f46877f60e414 (patch)
treedf28b2fa6611df7f1003f57447771edb69275761 /testsuites/tools/configure.ac
parent2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d7aecdc8f866b978a4349b0e157f46877f60e414.tar.bz2
2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* .cvsignore: Add autom4te.cache for autoconf > 2.52. * configure.in: Remove.
Diffstat (limited to '')
-rw-r--r--testsuites/tools/configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/tools/configure.ac b/testsuites/tools/configure.ac
new file mode 100644
index 0000000000..bb54219019
--- /dev/null
+++ b/testsuites/tools/configure.ac
@@ -0,0 +1,28 @@
+## Process this file with autoconf to produce a configure script.
+##
+## $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([generic])
+RTEMS_TOP(../../../..)
+AC_CONFIG_AUX_DIR(../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-tests-tools,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_TOOLPATHS
+AC_SUBST(program_prefix)
+
+RTEMS_CONFIG_BUILD_SUBDIRS(generic)
+if test -d $srcdir/$RTEMS_CPU; then
+AC_CONFIG_SUBDIRS($RTEMS_CPU)
+fi
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
+
+RTEMS_OUTPUT_BUILD_SUBDIRS(RTEMS_BUILD_SUBDIRS)