summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tmoverhd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-07 08:37:18 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-07 08:37:18 +0000
commit91de254961a733dea87530a3fbe5ecaf690ec8b8 (patch)
treef653f651e6dc218ed1f71fb0947ba52a7016a6cc /testsuites/tmtests/tmoverhd/Makefile.am
parent2005-11-07 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-91de254961a733dea87530a3fbe5ecaf690ec8b8.tar.bz2
Partial conversion to automake.
Diffstat (limited to 'testsuites/tmtests/tmoverhd/Makefile.am')
-rw-r--r--testsuites/tmtests/tmoverhd/Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/testsuites/tmtests/tmoverhd/Makefile.am b/testsuites/tmtests/tmoverhd/Makefile.am
index 19ff9da673..610a9262a0 100644
--- a/testsuites/tmtests/tmoverhd/Makefile.am
+++ b/testsuites/tmtests/tmoverhd/Makefile.am
@@ -6,24 +6,23 @@ TEST = tmoverhd
MANAGERS = io
-C_FILES = testtask.c empty.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = testtask.c empty.c
-H_FILES = system.h dumrtems.h
-noinst_HEADERS = $(H_FILES)
+lib_a_SOURCES += system.h dumrtems.h
DOCTYPES = doc
DOCS = $(DOCTYPES:%=$(TEST).%)
-SRCS = $(DOCS) $(C_FILES) $(H_FILES)
-OBJS = $(C_O_FILES)
+SRCS = $(DOCS)
+OBJS = $(lib_a_OBJECTS)
PRINT_SRCS = $(DOCS)
PGM = ${ARCH}/$(TEST).exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/amcompile.am
include $(top_srcdir)/../automake/leaf.am
include $(top_srcdir)/tmtests.am
@@ -39,7 +38,7 @@ ${PGM}: $(OBJS) $(LINK_FILES)
all-local: $(TMPINSTALL_FILES)
-EXTRA_DIST = $(C_FILES) $(DOCS)
+EXTRA_DIST = $(DOCS)
CLEANFILES = $(TMPINSTALL_FILES)