summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tm23/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-13 06:46:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-13 06:46:05 +0000
commita6b588d649d6fcc933aa356f3c36a1d2f6391976 (patch)
tree70ac33505ec6effe85d5875648a8c5a9c8479469 /testsuites/tmtests/tm23/Makefile.am
parent2005-11-13 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-a6b588d649d6fcc933aa356f3c36a1d2f6391976.tar.bz2
Convert to using *_PROGRAMS.
Diffstat (limited to 'testsuites/tmtests/tm23/Makefile.am')
-rw-r--r--testsuites/tmtests/tm23/Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/testsuites/tmtests/tm23/Makefile.am b/testsuites/tmtests/tm23/Makefile.am
index c8a28a77d6..61150e395b 100644
--- a/testsuites/tmtests/tm23/Makefile.am
+++ b/testsuites/tmtests/tm23/Makefile.am
@@ -4,31 +4,27 @@
MANAGERS = io event timer
-noinst_LIBRARIES = lib.a
-lib_a_SOURCES = task1.c system.h ../include/timesys.h
+rtems_tests_PROGRAMS = tm23.exe
+tm23_exe_SOURCES = task1.c system.h ../include/timesys.h
-testsdir = $(libdir)/tests
-docdir = $(testsdir)
+docdir = $(rtems_testsdir)
dist_doc_DATA = tm23.doc
-OBJS = $(lib_a_OBJECTS)
-
-PGM = ${ARCH}/tm23.exe
-
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-$(PGM): ${ARCH}/$(dirstamp)
+tm23_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
OPERATION_COUNT = @OPERATION_COUNT@
AM_CPPFLAGS += -I$(top_srcdir)/include -DOPERATION_COUNT=$(OPERATION_COUNT)
-
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-tests_SCRIPTS = $(PGM)
+LINK_OBJS = $(tm23_exe_OBJECTS) $(tm23_exe_LDADD)
+LINK_LIBS = $(tm23_exe_LDLIBS)
-$(PGM): $(OBJS) $(LINK_FILES)
+tm23.exe$(EXEEXT): $(tm23_exe_OBJECTS) $(tm23_exe_DEPENDENCIES)
+ @rm -f tm23.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am