summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tm17/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2009-04-03 12:55:13 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2009-04-03 12:55:13 +0000
commit3d5483771c21619e164e5a5cc308802027785dcc (patch)
treee5517f30599b1c7b69c80a159ccae6851146508e /testsuites/tmtests/tm17/Makefile.am
parent2009-04-03 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-3d5483771c21619e164e5a5cc308802027785dcc.tar.bz2
Eliminate _exe_/.exe.
Diffstat (limited to 'testsuites/tmtests/tm17/Makefile.am')
-rw-r--r--testsuites/tmtests/tm17/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/testsuites/tmtests/tm17/Makefile.am b/testsuites/tmtests/tm17/Makefile.am
index 556665ebb9..5c32fc0072 100644
--- a/testsuites/tmtests/tm17/Makefile.am
+++ b/testsuites/tmtests/tm17/Makefile.am
@@ -4,8 +4,8 @@
MANAGERS = io semaphore
-rtems_tests_PROGRAMS = tm17.exe
-tm17_exe_SOURCES = task1.c system.h ../include/timesys.h \
+rtems_tests_PROGRAMS = tm17
+tm17_SOURCES = task1.c system.h ../include/timesys.h \
../../support/src/tmtests_empty_function.c
dist_rtems_tests_DATA = tm17.doc
@@ -14,17 +14,17 @@ include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-tm17_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+tm17_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
OPERATION_COUNT = @OPERATION_COUNT@
AM_CPPFLAGS += -I$(top_srcdir)/include -DOPERATION_COUNT=$(OPERATION_COUNT)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-LINK_OBJS = $(tm17_exe_OBJECTS) $(tm17_exe_LDADD)
-LINK_LIBS = $(tm17_exe_LDLIBS)
+LINK_OBJS = $(tm17_OBJECTS) $(tm17_LDADD)
+LINK_LIBS = $(tm17_LDLIBS)
-tm17.exe$(EXEEXT): $(tm17_exe_OBJECTS) $(tm17_exe_DEPENDENCIES)
- @rm -f tm17.exe$(EXEEXT)
+tm17$(EXEEXT): $(tm17_OBJECTS) $(tm17_DEPENDENCIES)
+ @rm -f tm17$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am