summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/tm03/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-11 08:25:58 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-11 08:25:58 +0000
commitacdc144bdfa0ac3d854a987e8e7251337a402ab1 (patch)
tree007bbb501dc1e8979a1b4734a3903957648281b0 /testsuites/tmtests/tm03/Makefile.am
parent2005-11-11 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-acdc144bdfa0ac3d854a987e8e7251337a402ab1.tar.bz2
Expand tmtests.am.
Diffstat (limited to 'testsuites/tmtests/tm03/Makefile.am')
-rw-r--r--testsuites/tmtests/tm03/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/testsuites/tmtests/tm03/Makefile.am b/testsuites/tmtests/tm03/Makefile.am
index 15d810cdae..9138bde56d 100644
--- a/testsuites/tmtests/tm03/Makefile.am
+++ b/testsuites/tmtests/tm03/Makefile.am
@@ -19,7 +19,19 @@ PGM = ${ARCH}/$(TEST).exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-include $(top_srcdir)/tmtests.am
+
+project_bspdir=$(PROJECT_ROOT)
+
+$(project_bspdir)/tests/$(dirstamp):
+ @$(mkdir_p) $(project_bspdir)/tests
+ @: > $(project_bspdir)/tests/$(dirstamp)
+
+$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+ $(INSTALL_PROGRAM) $< $@
+
+TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
+
+$(PGM): ${ARCH}/$(dirstamp)
#
# (OPTIONAL) Add local stuff here using +=