summaryrefslogtreecommitdiffstats
path: root/testsuites/tmtests/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-07-10 14:20:39 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-07-14 19:31:00 -0500
commitb6343c61002b421e4d578e9868bedc1f0f0b43d7 (patch)
tree5c26dfacce2523537cb201e5f07de599cf454901 /testsuites/tmtests/configure.ac
parentcapture01: Add include of assert.h. (diff)
downloadrtems-b6343c61002b421e4d578e9868bedc1f0f0b43d7.tar.bz2
Enhance Semaphore Blocking and Readying Time Test Cases
tm02 and tm03 were modified to be reused for multiple configurations of RTEMS Classic API Semaphores. This added tm31-36. The messages for tm02 and tm03 were modified to indicate the semaphore attributes. tm31 - tm36 were added. This resulted in the following cases: tm02 - rtems_semaphore_obtain: Counting/FIFO not available caller blocks tm03 - rtems_semaphore_release: Counting/FIFO task readied preempts caller tm31 - rtems_semaphore_obtain: Counting/priority not available caller blocks tm32 - rtems_semaphore_release: Counting/priority task readied preempts caller tm33 - rtems_semaphore_obtain: Binary/FIFO not available caller blocks tm34 - rtems_semaphore_release: Binary/FIFO task readied preempts caller tm35 - rtems_semaphore_obtain: Binary/priority not available caller blocks tm36 - rtems_semaphore_release: Binary/priority task readied preempts caller
Diffstat (limited to '')
-rw-r--r--testsuites/tmtests/configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/testsuites/tmtests/configure.ac b/testsuites/tmtests/configure.ac
index 1e3241ffb3..0e3385c4d2 100644
--- a/testsuites/tmtests/configure.ac
+++ b/testsuites/tmtests/configure.ac
@@ -11,7 +11,6 @@ RTEMS_CANONICAL_TARGET_CPU
AM_INIT_AUTOMAKE([no-define foreign 1.12.2])
AM_MAINTAINER_MODE
-
RTEMS_ENV_RTEMSBSP
RTEMS_CHECK_RTEMS_TEST_NO_PAUSE
@@ -61,5 +60,11 @@ tm27/Makefile
tm28/Makefile
tm29/Makefile
tm30/Makefile
+tm31/Makefile
+tm32/Makefile
+tm33/Makefile
+tm34/Makefile
+tm35/Makefile
+tm36/Makefile
])
AC_OUTPUT