summaryrefslogtreecommitdiffstats
path: root/testsuites/tmitrontests/tmitronsem01/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-11 14:33:33 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-11 14:33:33 +0000
commit3bb5d9449078c07fa99b593b78cdcc2165badcdd (patch)
tree0d87bee26600e537e7445d8ba7924e410f7f1b8c /testsuites/tmitrontests/tmitronsem01/Makefile.am
parent2005-11-11 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-3bb5d9449078c07fa99b593b78cdcc2165badcdd.tar.bz2
Rework.
Diffstat (limited to '')
-rw-r--r--testsuites/tmitrontests/tmitronsem01/Makefile.am28
1 files changed, 6 insertions, 22 deletions
diff --git a/testsuites/tmitrontests/tmitronsem01/Makefile.am b/testsuites/tmitrontests/tmitronsem01/Makefile.am
index 6b1a4f1cd3..1dc25aafc9 100644
--- a/testsuites/tmitrontests/tmitronsem01/Makefile.am
+++ b/testsuites/tmitrontests/tmitronsem01/Makefile.am
@@ -2,48 +2,32 @@
## $Id$
##
-
MANAGERS = all
noinst_LIBRARIES = lib.a
lib_a_SOURCES = init.c system.h
-DOCS = tmitronsem01.doc
+testsdir = $(libdir)/tests
+docdir = $(testsdir)
+dist_doc_DATA = tmitronsem01.doc
OBJS = $(lib_a_OBJECTS)
-
PGM = ${ARCH}/tmitronsem01.exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-project_bspdir=$(PROJECT_ROOT)
-
-$(project_bspdir)/tests/$(dirstamp):
- @$(mkdir_p) $(project_bspdir)/tests
- @: > $(project_bspdir)/tests/$(dirstamp)
-
-$(project_bspdir)/tests/tmitronsem01.exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
- $(INSTALL_PROGRAM) $< $@
-
-TMPINSTALL_FILES = $(project_bspdir)/tests/tmitronsem01.exe
-
$(PGM): ${ARCH}/$(dirstamp)
-
OPERATION_COUNT = @OPERATION_COUNT@
AM_CPPFLAGS += -I$(top_srcdir)/include -DOPERATION_COUNT=$(OPERATION_COUNT)
AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-${PGM}: $(OBJS) $(LINK_FILES)
- $(make-exe)
-
-all-local: $(TMPINSTALL_FILES)
+tests_SCRIPTS = $(PGM)
-EXTRA_DIST = $(DOCS)
-
-CLEANFILES = $(TMPINSTALL_FILES)
+$(PGM): $(OBJS) $(LINK_FILES)
+ $(make-exe)
include $(top_srcdir)/../automake/local.am