summaryrefslogtreecommitdiffstats
path: root/testsuites/support/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 16:10:30 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 16:10:30 +0000
commit858896337ef30aa329a88533826fb172bf4e9556 (patch)
tree54233f46bd5a528c8efe1545d2aa12e0a0a4ad4a /testsuites/support/Makefile.am
parent2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-858896337ef30aa329a88533826fb172bf4e9556.tar.bz2
2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Use mkdir_p. Remove dirs from PRE/TMPINSTALL_FILES. Use include_HEADERS.
Diffstat (limited to 'testsuites/support/Makefile.am')
-rw-r--r--testsuites/support/Makefile.am24
1 files changed, 12 insertions, 12 deletions
diff --git a/testsuites/support/Makefile.am b/testsuites/support/Makefile.am
index 4083232d57..f6b07afa2e 100644
--- a/testsuites/support/Makefile.am
+++ b/testsuites/support/Makefile.am
@@ -4,22 +4,22 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-project_bspdir = $(PROJECT_ROOT)/@RTEMS_BSP@
+include_HEADERS = include/tmacros.h include/buffer_test_io.h
-noinst_HEADERS = include/tmacros.h include/buffer_test_io.h
+all-local: $(PREINSTALL_FILES)
-TMPINSTALLFILES = $(project_bspdir)/lib/include \
- $(project_bspdir)/lib/include/tmacros.h \
- $(project_bspdir)/lib/include/buffer_test_io.h
+PREINSTALL_FILES =
-$(project_bspdir)/lib/include:
- $(mkinstalldirs) $@
-$(project_bspdir)/lib/include/%.h: include/%.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/$(dirstamp):
+ @$(mkdir_p) $(PROJECT_INCLUDE)
+ @: > $(PROJECT_INCLUDE)/$(dirstamp)
-CLEANFILES = $(project_bspdir)/lib/include/tmacros.h \
- $(project_bspdir)/lib/include/buffer_test_io.h
+$(PROJECT_INCLUDE)/tmacros.h: include/tmacros.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/tmacros.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/tmacros.h
-all-local: $(TMPINSTALLFILES)
+$(PROJECT_INCLUDE)/buffer_test_io.h: include/buffer_test_io.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/buffer_test_io.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/buffer_test_io.h
include $(top_srcdir)/../automake/local.am