summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp73/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-03-11 16:39:27 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-03-11 16:39:27 +0000
commit89ed8a9055f7415bbbe989b1ee71ea86c3d511d6 (patch)
tree6760050a10855c86889d056792562d93136bd603 /testsuites/sptests/sp73/Makefile.am
parentRemove (Obsolete). (diff)
downloadrtems-89ed8a9055f7415bbbe989b1ee71ea86c3d511d6.tar.bz2
2011-03-11 Joel Sherrill <joel.sherrilL@OARcorp.com>
* Makefile.am, configure.ac: Add sp73. This is a new test designed to improve coverage of the thread yield logic. * sp73/.cvsignore, sp73/Makefile.am, sp73/init.c, sp73/sp73.doc, sp73/sp73.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/sptests/sp73/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/testsuites/sptests/sp73/Makefile.am b/testsuites/sptests/sp73/Makefile.am
new file mode 100644
index 0000000000..271ca2f723
--- /dev/null
+++ b/testsuites/sptests/sp73/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp73
+sp73_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp73.scn
+dist_rtems_tests_DATA += sp73.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp73_OBJECTS) $(sp73_LDADD)
+LINK_LIBS = $(sp73_LDLIBS)
+
+sp73$(EXEEXT): $(sp73_OBJECTS) $(sp73_DEPENDENCIES)
+ @rm -f sp73$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am