summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp71/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-22 16:14:43 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-22 16:14:43 +0000
commitdb904606e335ba7ae4e363a96f7a5e2a2700bf4e (patch)
tree299a3e61d23b0fd93e2b1c2475412f6e79d665a6 /testsuites/sptests/sp71/Makefile.am
parent2010-06-22 Jennifer Averett <Jennifer.Averett@OARcorp.com> (diff)
downloadrtems-db904606e335ba7ae4e363a96f7a5e2a2700bf4e.tar.bz2
2010-06-22 Joel Sherrill <joel.sherrilL@OARcorp.com>
* Makefile.am, configure.ac: Add new test to exercise path where using unlimited object support you are about to allocate more objects than can be represented in the Id. This test will NOT pass on targets with insufficient RAM. * sp71/.cvsignore, sp71/Makefile.am, sp71/init.c, sp71/sp71.doc, sp71/sp71.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/sptests/sp71/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/testsuites/sptests/sp71/Makefile.am b/testsuites/sptests/sp71/Makefile.am
new file mode 100644
index 0000000000..be4e42037a
--- /dev/null
+++ b/testsuites/sptests/sp71/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp71
+sp71_SOURCES = init.c ../../support/src/spin.c
+
+dist_rtems_tests_DATA = sp71.scn
+dist_rtems_tests_DATA += sp71.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp71_OBJECTS) $(sp71_LDADD)
+LINK_LIBS = $(sp71_LDLIBS)
+
+sp71$(EXEEXT): $(sp71_OBJECTS) $(sp71_DEPENDENCIES)
+ @rm -f sp71$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am