summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp66/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-14 20:05:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-09-14 20:05:44 +0000
commita5b04dabd923fcb3a9d1586d9ff01bdc81de83ba (patch)
tree7fa8a1d9c24a741cf28832d5f5cc005ba2ddc1ca /testsuites/sptests/sp66/Makefile.am
parent2009-09-14 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-a5b04dabd923fcb3a9d1586d9ff01bdc81de83ba.tar.bz2
2009-09-14 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac, sp65/init.c: Add new test to exercise very simple priority ceiling case that was previously only tested via the POSIX API. * sp66/.cvsignore, sp66/Makefile.am, sp66/init.c, sp66/sp66.doc, sp66/sp66.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp66/Makefile.am')
-rw-r--r--testsuites/sptests/sp66/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/sptests/sp66/Makefile.am b/testsuites/sptests/sp66/Makefile.am
new file mode 100644
index 0000000000..b40cdc5148
--- /dev/null
+++ b/testsuites/sptests/sp66/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp66
+sp66_SOURCES = ../sp65/init.c
+
+dist_rtems_tests_DATA = sp66.scn
+dist_rtems_tests_DATA += sp66.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp66_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+AM_CPPFLAGS += -DINHERIT_CEILING
+
+LINK_OBJS = $(sp66_OBJECTS) $(sp66_LDADD)
+LINK_LIBS = $(sp66_LDLIBS)
+
+sp66$(EXEEXT): $(sp66_OBJECTS) $(sp66_DEPENDENCIES)
+ @rm -f sp66$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am