summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp64/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-05 20:58:17 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-08-05 20:58:17 +0000
commitabc4af35f87e8e0122d3b26fef9ed830694c4156 (patch)
tree0283d44c1c228c963f423e9c817ca5a009acb4a7 /testsuites/sptests/sp64/Makefile.am
parent2009-08-05 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-abc4af35f87e8e0122d3b26fef9ed830694c4156.tar.bz2
2009-08-05 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac, sp63/init.c: Add new test for exercising when we are unable to allocate the memory needed for an object extend. Make sure all is handled properly. * sp64/.cvsignore, sp64/Makefile.am, sp64/init.c, sp64/sp64.doc, sp64/sp64.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/sptests/sp64/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/sptests/sp64/Makefile.am b/testsuites/sptests/sp64/Makefile.am
new file mode 100644
index 0000000000..7ea889f95d
--- /dev/null
+++ b/testsuites/sptests/sp64/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp64
+sp64_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp64.scn
+dist_rtems_tests_DATA += sp64.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp64_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp64_OBJECTS) $(sp64_LDADD)
+LINK_LIBS = $(sp64_LDLIBS)
+
+sp64$(EXEEXT): $(sp64_OBJECTS) $(sp64_DEPENDENCIES)
+ @rm -f sp64$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am