summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp59/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-09 20:23:38 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-09 20:23:38 +0000
commit8f9b2f6026dc42c84540388bd985c60b65040180 (patch)
tree411c9358470a98570f7f1b6a8d18cd6533e14ef2 /testsuites/sptests/sp59/Makefile.am
parent2009-07-09 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-8f9b2f6026dc42c84540388bd985c60b65040180.tar.bz2
2009-07-09 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add sp59 to test path through _Thread_queue_First_priority where the task's priority was in the bottom 1/4 of the range. * sp59/.cvsignore, sp59/Makefile.am, sp59/init.c, sp59/sp59.doc, sp59/sp59.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/sptests/sp59/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp59/Makefile.am b/testsuites/sptests/sp59/Makefile.am
new file mode 100644
index 0000000000..2db9dc035a
--- /dev/null
+++ b/testsuites/sptests/sp59/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp59
+sp59_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp59.scn
+dist_rtems_tests_DATA += sp59.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp59_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp59_OBJECTS) $(sp59_LDADD)
+LINK_LIBS = $(sp59_LDLIBS)
+
+sp59$(EXEEXT): $(sp59_OBJECTS) $(sp59_DEPENDENCIES)
+ @rm -f sp59$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am