summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp46/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-12-04 15:58:49 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-12-04 15:58:49 +0000
commited348c8a7af4644eec114b11f36f416a8b93b908 (patch)
tree8159ceb2aaf4b2ec7e2b4b811710ef75d1f84d94 /testsuites/sptests/sp46/Makefile.am
parent2008-12-04 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-ed348c8a7af4644eec114b11f36f416a8b93b908.tar.bz2
2008-12-04 Joel Sherrill <joel.sherrill@oarcorp.com>
PR 1348/cpukit * Makefile.am, configure.ac: Add test of special case of resetting cpu usage information while a period is running. * sp46/.cvsignore, sp46/Makefile.am, sp46/init.c, sp46/sp46.doc, sp46/sp46.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/sptests/sp46/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/sptests/sp46/Makefile.am b/testsuites/sptests/sp46/Makefile.am
new file mode 100644
index 0000000000..d90ebff661
--- /dev/null
+++ b/testsuites/sptests/sp46/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp46.exe
+sp46_exe_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp46.scn
+dist_rtems_tests_DATA += sp46.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp46_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp46_exe_OBJECTS) $(sp46_exe_LDADD)
+LINK_LIBS = $(sp46_exe_LDLIBS)
+
+sp46.exe$(EXEEXT): $(sp46_exe_OBJECTS) $(sp46_exe_DEPENDENCIES)
+ @rm -f sp46.exe$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am