summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/sp44/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-08-05 13:10:26 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-08-05 13:10:26 +0000
commitcccd632c8de2abfffbabaf2b25e0e03366618758 (patch)
tree18dbacd93f2da02b14eb4bb40d4121e00bb86fb5 /testsuites/sptests/sp44/Makefile.am
parent2008-08-05 Xudong Guan <xudong.guan@criticalsoftware.com> (diff)
downloadrtems-cccd632c8de2abfffbabaf2b25e0e03366618758.tar.bz2
2008-08-05 Xudong Guan <xudong.guan@criticalsoftware.com>
PR 1212/cpukit * Makefile.am, configure.ac: Time slicing will not happen if the task mode is changed from a non-timeslicing mode to timeslicing mode if it is done by the executing thread (e.g. in its task body). This change includes sp44 to demonstrate the problem and verify the correction. * sp44/.cvsignore, sp44/Makefile.am, sp44/init.c, sp44/sp44.scn: New files.
Diffstat (limited to 'testsuites/sptests/sp44/Makefile.am')
-rw-r--r--testsuites/sptests/sp44/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/testsuites/sptests/sp44/Makefile.am b/testsuites/sptests/sp44/Makefile.am
new file mode 100644
index 0000000000..7b1b5e4b36
--- /dev/null
+++ b/testsuites/sptests/sp44/Makefile.am
@@ -0,0 +1,27 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = sp44.exe
+sp44_exe_SOURCES = init.c
+
+dist_rtems_tests_DATA = sp44.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+sp44_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(sp44_exe_OBJECTS) $(sp44_exe_LDADD)
+LINK_LIBS = $(sp44_exe_LDLIBS)
+
+sp44.exe$(EXEEXT): $(sp44_exe_OBJECTS) $(sp44_exe_DEPENDENCIES)
+ @rm -f sp44.exe$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am