summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2018-04-09 13:45:15 +1000
committerChris Johns <chrisj@rtems.org>2018-04-10 08:24:54 +1000
commitbc0675393dec97c466ec18e3226339a43db6fe54 (patch)
treee136c36bee0b4c245ca77807ffb9d93994d2c63a /testsuites/sptests/configure.ac
parenttestsuite/smptests: Merged nested Makefile.am files into one Makefile.am (diff)
downloadrtems-bc0675393dec97c466ec18e3226339a43db6fe54.tar.bz2
testsuite/sptests: Merged nested Makefile.am files into one Makefile.am
This change is part of the testsuite Makefile.am reorganization. Update #3382
Diffstat (limited to 'testsuites/sptests/configure.ac')
-rw-r--r--testsuites/sptests/configure.ac441
1 files changed, 221 insertions, 220 deletions
diff --git a/testsuites/sptests/configure.ac b/testsuites/sptests/configure.ac
index 2ebc5541c9..a80b4ebe28 100644
--- a/testsuites/sptests/configure.ac
+++ b/testsuites/sptests/configure.ac
@@ -34,226 +34,227 @@ AC_CHECK_SIZEOF([time_t])
# Some tests should not be built/run in SMP configurations
RTEMS_CHECK_CPUOPTS([RTEMS_SMP])
+AM_CONDITIONAL(NO_SMP,test "$rtems_cv_RTEMS_SMP" != "yes")
AM_CONDITIONAL(HAS_SMP,test "$rtems_cv_RTEMS_SMP" = "yes")
-# Explicitly list all Makefiles here
-AC_CONFIG_FILES([Makefile
-spthread01/Makefile
-sptls04/Makefile
-spconsole01/Makefile
-spintrcritical24/Makefile
-spfatal31/Makefile
-spfatal30/Makefile
-spmutex01/Makefile
-spextensions01/Makefile
-sptimerserver01/Makefile
-spsysinit01/Makefile
-splinkersets01/Makefile
-spstdthreads01/Makefile
-spsyslock01/Makefile
-sptasknopreempt01/Makefile
-spintrcritical23/Makefile
-sptimecounter01/Makefile
-sptimecounter02/Makefile
-sptimecounter03/Makefile
-sptimecounter04/Makefile
-spatomic01/Makefile
-spglobalcon01/Makefile
-spglobalcon02/Makefile
-spintrcritical22/Makefile
-spsem03/Makefile
-spmrsp01/Makefile
-spscheduler01/Makefile
-spfatal28/Makefile
-spthreadlife01/Makefile
-spprofiling01/Makefile
-spcache01/Makefile
-sptls03/Makefile
-spcpucounter01/Makefile
-sptls02/Makefile
-sptls01/Makefile
-spintrcritical20/Makefile
-spintrcritical21/Makefile
-spcontext01/Makefile
-spfatal26/Makefile
-spinternalerror02/Makefile
-spinternalerror01/Makefile
-speventsystem01/Makefile
-speventtransient01/Makefile
-spintrcritical18/Makefile
-sp01/Makefile
-sp02/Makefile
-sp03/Makefile
-sp04/Makefile
-sp05/Makefile
-sp06/Makefile
-sp07/Makefile
-sp08/Makefile
-sp11/Makefile
-sp12/Makefile
-sp13/Makefile
-sp14/Makefile
-sp15/Makefile
-sp16/Makefile
-sp17/Makefile
-sp18/Makefile
-sp19/Makefile
-sp20/Makefile
-sp21/Makefile
-sp22/Makefile
-sp23/Makefile
-sp24/Makefile
-sp25/Makefile
-sp26/Makefile
-sp27/Makefile
-sp27a/Makefile
-sp29/Makefile
-sp30/Makefile
-sp31/Makefile
-sp32/Makefile
-sp33/Makefile
-sp34/Makefile
-sp35/Makefile
-sp36/Makefile
-sp37/Makefile
-sp38/Makefile
-sp40/Makefile
-sp41/Makefile
-sp42/Makefile
-sp43/Makefile
-sp44/Makefile
-sp45/Makefile
-sp46/Makefile
-sp47/Makefile
-sp48/Makefile
-sp49/Makefile
-sp50/Makefile
-sp51/Makefile
-sp52/Makefile
-sp53/Makefile
-sp54/Makefile
-sp55/Makefile
-sp56/Makefile
-sp57/Makefile
-sp58/Makefile
-sp59/Makefile
-sp60/Makefile
-sp62/Makefile
-sp63/Makefile
-sp64/Makefile
-sp65/Makefile
-sp66/Makefile
-sp67/Makefile
-sp68/Makefile
-sp69/Makefile
-sp70/Makefile
-sp71/Makefile
-sp72/Makefile
-sp73/Makefile
-sp74/Makefile
-sp75/Makefile
-sp76/Makefile
-sp77/Makefile
-sprmsched02/Makefile
-sp2038/Makefile
-spassoc01/Makefile
-spcbssched01/Makefile
-spcbssched02/Makefile
-spcbssched03/Makefile
-spchain/Makefile
-spclock_err01/Makefile
-spclock_err02/Makefile
-spcoverage/Makefile
-spedfsched01/Makefile
-spedfsched02/Makefile
-spedfsched03/Makefile
-spedfsched04/Makefile
-sperror01/Makefile
-sperror02/Makefile
-sperror03/Makefile
-spevent_err03/Makefile
-spfatal01/Makefile
-spfatal02/Makefile
-spfatal03/Makefile
-spfatal04/Makefile
-spfatal05/Makefile
-spfatal06/Makefile
-spfatal07/Makefile
-spfatal08/Makefile
-spfatal09/Makefile
-spfatal10/Makefile
-spfatal11/Makefile
-spfatal12/Makefile
-spfatal13/Makefile
-spfatal14/Makefile
-spfatal15/Makefile
-spfatal16/Makefile
-spfatal24/Makefile
-spfatal25/Makefile
-spfatal27/Makefile
-spfatal29/Makefile
-spfifo01/Makefile
-spfifo02/Makefile
-spfifo03/Makefile
-spfifo04/Makefile
-spfifo05/Makefile
-spfreechain01/Makefile
-spintr_err01/Makefile
-spintrcritical01/Makefile
-spintrcritical02/Makefile
-spintrcritical03/Makefile
-spintrcritical04/Makefile
-spintrcritical05/Makefile
-spintrcritical06/Makefile
-spintrcritical07/Makefile
-spintrcritical08/Makefile
-spintrcritical09/Makefile
-spintrcritical10/Makefile
-spintrcritical11/Makefile
-spintrcritical12/Makefile
-spintrcritical13/Makefile
-spintrcritical14/Makefile
-spintrcritical15/Makefile
-spintrcritical16/Makefile
-spheapprot/Makefile
-spmkdir/Makefile
-spmountmgr01/Makefile
-spmsgq_err01/Makefile
-spmsgq_err02/Makefile
-spnsext01/Makefile
-spobjgetnext/Makefile
-sppagesize/Makefile
-spport_err01/Makefile
-spprintk/Makefile
-spprivenv01/Makefile
-spqreslib/Makefile
-spratemon_err01/Makefile
-sprbtree01/Makefile
-spsem_err01/Makefile
-spsem_err02/Makefile
-spsem01/Makefile
-spsem02/Makefile
-spsignal_err01/Makefile
-spsimplesched01/Makefile
-spsimplesched02/Makefile
-spsimplesched03/Makefile
-spsize/Makefile
-spstkalloc/Makefile
-spstkalloc02/Makefile
-spthreadq01/Makefile
-sptimespec01/Makefile
-spwatchdog/Makefile
-spwkspace/Makefile
-sptask_err01/Makefile
-sptask_err02/Makefile
-sptask_err03/Makefile
-sptask_err04/Makefile
-sptimer_err01/Makefile
-sptimer_err02/Makefile
-spcpuset01/Makefile
-spregion_err01/Makefile
-sppartition_err01/Makefile
-sprmsched01/Makefile
-spversion01/Makefile
-])
+# BSP Test configuration
+RTEMS_TEST_CHECK([sp01])
+RTEMS_TEST_CHECK([sp02])
+RTEMS_TEST_CHECK([sp03])
+RTEMS_TEST_CHECK([sp04])
+RTEMS_TEST_CHECK([sp05])
+RTEMS_TEST_CHECK([sp06])
+RTEMS_TEST_CHECK([sp07])
+RTEMS_TEST_CHECK([sp08])
+RTEMS_TEST_CHECK([sp11])
+RTEMS_TEST_CHECK([sp12])
+RTEMS_TEST_CHECK([sp13])
+RTEMS_TEST_CHECK([sp14])
+RTEMS_TEST_CHECK([sp15])
+RTEMS_TEST_CHECK([sp16])
+RTEMS_TEST_CHECK([sp17])
+RTEMS_TEST_CHECK([sp18])
+RTEMS_TEST_CHECK([sp19])
+RTEMS_TEST_CHECK([sp20])
+RTEMS_TEST_CHECK([sp2038])
+RTEMS_TEST_CHECK([sp21])
+RTEMS_TEST_CHECK([sp22])
+RTEMS_TEST_CHECK([sp23])
+RTEMS_TEST_CHECK([sp24])
+RTEMS_TEST_CHECK([sp25])
+RTEMS_TEST_CHECK([sp26])
+RTEMS_TEST_CHECK([sp27])
+RTEMS_TEST_CHECK([sp27a])
+RTEMS_TEST_CHECK([sp29])
+RTEMS_TEST_CHECK([sp30])
+RTEMS_TEST_CHECK([sp31])
+RTEMS_TEST_CHECK([sp32])
+RTEMS_TEST_CHECK([sp33])
+RTEMS_TEST_CHECK([sp34])
+RTEMS_TEST_CHECK([sp35])
+RTEMS_TEST_CHECK([sp36])
+RTEMS_TEST_CHECK([sp37])
+RTEMS_TEST_CHECK([sp38])
+RTEMS_TEST_CHECK([sp40])
+RTEMS_TEST_CHECK([sp41])
+RTEMS_TEST_CHECK([sp42])
+RTEMS_TEST_CHECK([sp43])
+RTEMS_TEST_CHECK([sp44])
+RTEMS_TEST_CHECK([sp45])
+RTEMS_TEST_CHECK([sp46])
+RTEMS_TEST_CHECK([sp47])
+RTEMS_TEST_CHECK([sp48])
+RTEMS_TEST_CHECK([sp49])
+RTEMS_TEST_CHECK([sp50])
+RTEMS_TEST_CHECK([sp51])
+RTEMS_TEST_CHECK([sp52])
+RTEMS_TEST_CHECK([sp53])
+RTEMS_TEST_CHECK([sp54])
+RTEMS_TEST_CHECK([sp55])
+RTEMS_TEST_CHECK([sp56])
+RTEMS_TEST_CHECK([sp57])
+RTEMS_TEST_CHECK([sp58])
+RTEMS_TEST_CHECK([sp59])
+RTEMS_TEST_CHECK([sp60])
+RTEMS_TEST_CHECK([sp62])
+RTEMS_TEST_CHECK([sp63])
+RTEMS_TEST_CHECK([sp64])
+RTEMS_TEST_CHECK([sp65])
+RTEMS_TEST_CHECK([sp66])
+RTEMS_TEST_CHECK([sp67])
+RTEMS_TEST_CHECK([sp68])
+RTEMS_TEST_CHECK([sp69])
+RTEMS_TEST_CHECK([sp70])
+RTEMS_TEST_CHECK([sp71])
+RTEMS_TEST_CHECK([sp72])
+RTEMS_TEST_CHECK([sp73])
+RTEMS_TEST_CHECK([sp74])
+RTEMS_TEST_CHECK([sp75])
+RTEMS_TEST_CHECK([sp76])
+RTEMS_TEST_CHECK([sp77])
+RTEMS_TEST_CHECK([spassoc01])
+RTEMS_TEST_CHECK([spatomic01])
+RTEMS_TEST_CHECK([spcache01])
+RTEMS_TEST_CHECK([spcbssched01])
+RTEMS_TEST_CHECK([spcbssched02])
+RTEMS_TEST_CHECK([spcbssched03])
+RTEMS_TEST_CHECK([spchain])
+RTEMS_TEST_CHECK([spclock_err01])
+RTEMS_TEST_CHECK([spclock_err02])
+RTEMS_TEST_CHECK([spconsole01])
+RTEMS_TEST_CHECK([spcontext01])
+RTEMS_TEST_CHECK([spcoverage])
+RTEMS_TEST_CHECK([spcpucounter01])
+RTEMS_TEST_CHECK([spcpuset01])
+RTEMS_TEST_CHECK([spedfsched01])
+RTEMS_TEST_CHECK([spedfsched02])
+RTEMS_TEST_CHECK([spedfsched03])
+RTEMS_TEST_CHECK([spedfsched04])
+RTEMS_TEST_CHECK([sperror01])
+RTEMS_TEST_CHECK([sperror02])
+RTEMS_TEST_CHECK([sperror03])
+RTEMS_TEST_CHECK([spevent_err03])
+RTEMS_TEST_CHECK([speventsystem01])
+RTEMS_TEST_CHECK([speventtransient01])
+RTEMS_TEST_CHECK([spextensions01])
+RTEMS_TEST_CHECK([spfatal01])
+RTEMS_TEST_CHECK([spfatal02])
+RTEMS_TEST_CHECK([spfatal03])
+RTEMS_TEST_CHECK([spfatal04])
+RTEMS_TEST_CHECK([spfatal05])
+RTEMS_TEST_CHECK([spfatal06])
+RTEMS_TEST_CHECK([spfatal07])
+RTEMS_TEST_CHECK([spfatal08])
+RTEMS_TEST_CHECK([spfatal09])
+RTEMS_TEST_CHECK([spfatal10])
+RTEMS_TEST_CHECK([spfatal11])
+RTEMS_TEST_CHECK([spfatal12])
+RTEMS_TEST_CHECK([spfatal13])
+RTEMS_TEST_CHECK([spfatal14])
+RTEMS_TEST_CHECK([spfatal15])
+RTEMS_TEST_CHECK([spfatal16])
+RTEMS_TEST_CHECK([spfatal24])
+RTEMS_TEST_CHECK([spfatal25])
+RTEMS_TEST_CHECK([spfatal26])
+RTEMS_TEST_CHECK([spfatal27])
+RTEMS_TEST_CHECK([spfatal28])
+RTEMS_TEST_CHECK([spfatal29])
+RTEMS_TEST_CHECK([spfatal30])
+RTEMS_TEST_CHECK([spfatal31])
+RTEMS_TEST_CHECK([spfifo01])
+RTEMS_TEST_CHECK([spfifo02])
+RTEMS_TEST_CHECK([spfifo03])
+RTEMS_TEST_CHECK([spfifo04])
+RTEMS_TEST_CHECK([spfifo05])
+RTEMS_TEST_CHECK([spfreechain01])
+RTEMS_TEST_CHECK([spglobalcon01])
+RTEMS_TEST_CHECK([spglobalcon02])
+RTEMS_TEST_CHECK([spheapprot])
+RTEMS_TEST_CHECK([spinternalerror01])
+RTEMS_TEST_CHECK([spinternalerror02])
+RTEMS_TEST_CHECK([spintr_err01])
+RTEMS_TEST_CHECK([spintrcritical01])
+RTEMS_TEST_CHECK([spintrcritical02])
+RTEMS_TEST_CHECK([spintrcritical03])
+RTEMS_TEST_CHECK([spintrcritical04])
+RTEMS_TEST_CHECK([spintrcritical05])
+RTEMS_TEST_CHECK([spintrcritical06])
+RTEMS_TEST_CHECK([spintrcritical07])
+RTEMS_TEST_CHECK([spintrcritical08])
+RTEMS_TEST_CHECK([spintrcritical09])
+RTEMS_TEST_CHECK([spintrcritical10])
+RTEMS_TEST_CHECK([spintrcritical11])
+RTEMS_TEST_CHECK([spintrcritical12])
+RTEMS_TEST_CHECK([spintrcritical13])
+RTEMS_TEST_CHECK([spintrcritical14])
+RTEMS_TEST_CHECK([spintrcritical15])
+RTEMS_TEST_CHECK([spintrcritical16])
+RTEMS_TEST_CHECK([spintrcritical18])
+RTEMS_TEST_CHECK([spintrcritical20])
+RTEMS_TEST_CHECK([spintrcritical21])
+RTEMS_TEST_CHECK([spintrcritical22])
+RTEMS_TEST_CHECK([spintrcritical23])
+RTEMS_TEST_CHECK([spintrcritical24])
+RTEMS_TEST_CHECK([splinkersets01])
+RTEMS_TEST_CHECK([spmkdir])
+RTEMS_TEST_CHECK([spmountmgr01])
+RTEMS_TEST_CHECK([spmrsp01])
+RTEMS_TEST_CHECK([spmsgq_err01])
+RTEMS_TEST_CHECK([spmsgq_err02])
+RTEMS_TEST_CHECK([spmutex01])
+RTEMS_TEST_CHECK([spnsext01])
+RTEMS_TEST_CHECK([spobjgetnext])
+RTEMS_TEST_CHECK([sppagesize])
+RTEMS_TEST_CHECK([sppartition_err01])
+RTEMS_TEST_CHECK([spport_err01])
+RTEMS_TEST_CHECK([spprintk])
+RTEMS_TEST_CHECK([spprivenv01])
+RTEMS_TEST_CHECK([spprofiling01])
+RTEMS_TEST_CHECK([spqreslib])
+RTEMS_TEST_CHECK([spratemon_err01])
+RTEMS_TEST_CHECK([sprbtree01])
+RTEMS_TEST_CHECK([spregion_err01])
+RTEMS_TEST_CHECK([sprmsched01])
+RTEMS_TEST_CHECK([sprmsched02])
+RTEMS_TEST_CHECK([spscheduler01])
+RTEMS_TEST_CHECK([spsem01])
+RTEMS_TEST_CHECK([spsem02])
+RTEMS_TEST_CHECK([spsem03])
+RTEMS_TEST_CHECK([spsem_err01])
+RTEMS_TEST_CHECK([spsem_err02])
+RTEMS_TEST_CHECK([spsignal_err01])
+RTEMS_TEST_CHECK([spsimplesched01])
+RTEMS_TEST_CHECK([spsimplesched02])
+RTEMS_TEST_CHECK([spsimplesched03])
+RTEMS_TEST_CHECK([spsize])
+RTEMS_TEST_CHECK([spstdthreads01])
+RTEMS_TEST_CHECK([spstkalloc])
+RTEMS_TEST_CHECK([spstkalloc02])
+RTEMS_TEST_CHECK([spsysinit01])
+RTEMS_TEST_CHECK([spsyslock01])
+RTEMS_TEST_CHECK([sptask_err01])
+RTEMS_TEST_CHECK([sptask_err02])
+RTEMS_TEST_CHECK([sptask_err03])
+RTEMS_TEST_CHECK([sptask_err04])
+RTEMS_TEST_CHECK([sptasknopreempt01])
+RTEMS_TEST_CHECK([spthread01])
+RTEMS_TEST_CHECK([spthreadlife01])
+RTEMS_TEST_CHECK([spthreadq01])
+RTEMS_TEST_CHECK([sptimecounter01])
+RTEMS_TEST_CHECK([sptimecounter02])
+RTEMS_TEST_CHECK([sptimecounter03])
+RTEMS_TEST_CHECK([sptimecounter04])
+RTEMS_TEST_CHECK([sptimer_err01])
+RTEMS_TEST_CHECK([sptimer_err02])
+RTEMS_TEST_CHECK([sptimerserver01])
+RTEMS_TEST_CHECK([sptimespec01])
+RTEMS_TEST_CHECK([sptls01])
+RTEMS_TEST_CHECK([sptls02])
+RTEMS_TEST_CHECK([sptls03])
+RTEMS_TEST_CHECK([sptls04])
+RTEMS_TEST_CHECK([spversion01])
+RTEMS_TEST_CHECK([spwatchdog])
+RTEMS_TEST_CHECK([spwkspace])
+
+AC_CONFIG_FILES([Makefile])
AC_OUTPUT