summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-15 16:53:27 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-21 11:21:04 +0200
commitfe46647ef5671095d17734792a1dcc675d54d34c (patch)
treed75f9586408ff4df3de9ccb2dbf4351ddf00e7ab /testsuites/sptests/Makefile.am
parentstackchk: Add SMP support (diff)
downloadrtems-fe46647ef5671095d17734792a1dcc675d54d34c.tar.bz2
score: Macros to declare and define global symbols
Add RTEMS_DEFINE_GLOBAL_SYMBOL() and add RTEMS_DECLARE_GLOBAL_SYMBOL(). Update #3459.
Diffstat (limited to 'testsuites/sptests/Makefile.am')
-rw-r--r--testsuites/sptests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
index 8519702bb1..d3a2e10869 100644
--- a/testsuites/sptests/Makefile.am
+++ b/testsuites/sptests/Makefile.am
@@ -1493,6 +1493,15 @@ spmkdir_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spmkdir) \
$(support_includes)
endif
+if TEST_spmisc01
+sp_tests += spmisc01
+sp_screens += spmisc01/spmisc01.scn
+sp_docs += spmisc01/spmisc01.doc
+spmisc01_SOURCES = spmisc01/init.c
+spmisc01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spmisc01) \
+ $(support_includes)
+endif
+
if TEST_spmountmgr01
sp_tests += spmountmgr01
sp_screens += spmountmgr01/spmountmgr01.scn