summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-11-06 12:57:42 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-11-07 07:52:51 +0100
commite71c097ac33bdb20a8121174a6d1d78a720f4ac4 (patch)
tree28b483b12b5a64ddf51d5ad54e85257a2b7d6922 /testsuites/sptests/Makefile.am
parentbuild: Remove superfluous psxtmonce01/Makefile.am (diff)
downloadrtems-e71c097ac33bdb20a8121174a6d1d78a720f4ac4.tar.bz2
spconfig02: Check object methods in default config
Ensure that the creation of Classic API objects fails with the expected status code in the default configuration. Ensure that the deletion of Classic API objects fails with the expected status code in the default configuration if the identifier is invalid. Ensure that only the expected objects are present in the default configuration via rtems_object_get_classic_name().
Diffstat (limited to 'testsuites/sptests/Makefile.am')
-rw-r--r--testsuites/sptests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
index 7a182430b0..80680dfe83 100644
--- a/testsuites/sptests/Makefile.am
+++ b/testsuites/sptests/Makefile.am
@@ -717,6 +717,15 @@ spconfig01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spconfig01) \
$(support_includes)
endif
+if TEST_spconfig02
+sp_tests += spconfig02
+sp_screens += spconfig02/spconfig02.scn
+sp_docs += spconfig02/spconfig02.doc
+spconfig02_SOURCES = spconfig02/init.c
+spconfig02_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spconfig02) \
+ $(support_includes)
+endif
+
if TEST_spconsole01
sp_tests += spconsole01
sp_screens += spconsole01/spconsole01.scn