summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-01 07:04:45 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-06-05 08:49:56 +0200
commitde9b7d712bf5da6593386fd4fbca0d5f8b8431d8 (patch)
tree0f5716349a3a50243bd24f2cb9eaed280d88e3e8 /testsuites/sptests/Makefile.am
parentUpdate rtems_fatal_source_text() (diff)
downloadrtems-de9b7d712bf5da6593386fd4fbca0d5f8b8431d8.tar.bz2
Add RTEMS_FATAL_SOURCE_INVALID_HEAP_FREE
An invalid heap usage such as a double free is usually a fatal error since this indicates a use after free. Replace the use of printk() in free() with a fatal error. Update #3437.
Diffstat (limited to '')
-rw-r--r--testsuites/sptests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
index 1d8f153d1d..8519702bb1 100644
--- a/testsuites/sptests/Makefile.am
+++ b/testsuites/sptests/Makefile.am
@@ -1098,6 +1098,16 @@ spfatal31_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal31) \
$(support_includes)
endif
+if TEST_spfatal32
+sp_tests += spfatal32
+sp_screens += spfatal32/spfatal32.scn
+sp_docs += spfatal32/spfatal32.doc
+spfatal32_SOURCES = spfatal_support/init.c spfatal_support/system.h \
+ spfatal32/testcase.h
+spfatal32_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal32) \
+ $(support_includes) -I$(top_srcdir)/spfatal32
+endif
+
if TEST_spfifo01
sp_tests += spfifo01
sp_screens += spfifo01/spfifo01.scn