summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-05-23 10:00:33 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-06-03 08:15:16 +0200
commit3e2011394db1f56420c634e9b3d0af8530723485 (patch)
treea4e45f3f0431ee05f7aa8633b02976d31fbbd08e /testsuites/sptests/Makefile.am
parentlibblock: Add RTEMS_BDBUF_USE_PTHREAD (diff)
downloadrtems-3e2011394db1f56420c634e9b3d0af8530723485.tar.bz2
score: Add Resource Handler
A resource is something that has at most one owner at a time and may have multiple rivals in case an owner is present. The owner and rivals are impersonated via resource nodes. A resource is represented via the resource control structure. The resource controls and nodes are organized as trees. It is possible to detect deadlocks via such a resource tree. The _Resource_Iterate() function can be used to iterate through such a resource tree starting at a top node.
Diffstat (limited to '')
-rw-r--r--testsuites/sptests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
index cc5ed2628c..e55061e757 100644
--- a/testsuites/sptests/Makefile.am
+++ b/testsuites/sptests/Makefile.am
@@ -37,6 +37,7 @@ if HAS_SMP
else
_SUBDIRS += sp29
endif
+_SUBDIRS += spresource01
_SUBDIRS += spmrsp01
_SUBDIRS += spscheduler01
_SUBDIRS += spprofiling01