summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-12-19 09:25:29 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-12-21 07:56:35 +0100
commit2158621366c19dc32418ace48f49f4474a40c669 (patch)
tree424b6457086884a6ed0cdbef8366c23992e03cbc /testsuites/sptests/Makefile.am
parenttftpfs: Some bug fixes (diff)
downloadrtems-2158621366c19dc32418ace48f49f4474a40c669.tar.bz2
Add aligned_alloc() and memalign()
Ensure that the C++17 aligned new operator works. Close #3666.
Diffstat (limited to '')
-rw-r--r--testsuites/sptests/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
index 8f92873d2b..a3c9b1e3bf 100644
--- a/testsuites/sptests/Makefile.am
+++ b/testsuites/sptests/Makefile.am
@@ -772,6 +772,18 @@ spcpuset01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spcpuset01) \
$(support_includes) -DSMPTEST
endif
+if HAS_CPLUSPLUS
+if TEST_spcxx01
+sp_tests += spcxx01
+sp_screens += spcxx01/spcxx01.scn
+sp_docs += spcxx01/spcxx01.doc
+spcxx01_SOURCES = spcxx01/init.cc
+spcxx01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spcxx01) \
+ $(support_includes)
+spcxx01_CXXFLAGS = $(AM_CXXFLAGS) -std=gnu++17
+endif
+endif
+
if TEST_spedfsched01
sp_tests += spedfsched01
sp_screens += spedfsched01/spedfsched01.scn