summaryrefslogtreecommitdiffstats
path: root/testsuites/sptests/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-11-11 20:08:46 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2019-11-12 09:47:20 +0100
commit1a48cbfa16bf54a442f9394e4c4d9c2211e82865 (patch)
tree929eba7ba5e91ae9ae31f77547353dbb04ea5da4 /testsuites/sptests/Makefile.am
parenttests: Simplify fatal error test support (diff)
downloadrtems-1a48cbfa16bf54a442f9394e4c4d9c2211e82865.tar.bz2
sptests: Avoid include path magic
Update #3818.
Diffstat (limited to '')
-rw-r--r--testsuites/sptests/Makefile.am95
1 files changed, 38 insertions, 57 deletions
diff --git a/testsuites/sptests/Makefile.am b/testsuites/sptests/Makefile.am
index 900a2f80d4..09751b6d58 100644
--- a/testsuites/sptests/Makefile.am
+++ b/testsuites/sptests/Makefile.am
@@ -890,150 +890,135 @@ if TEST_spfatal01
sp_tests += spfatal01
sp_screens += spfatal01/spfatal01.scn
sp_docs += spfatal01/spfatal01.doc
-spfatal01_SOURCES = spfatal_support/init.c \
- spfatal01/testcase.h
+spfatal01_SOURCES = spfatal01/init.c
spfatal01_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal01) \
- $(support_includes) -I$(top_srcdir)/spfatal01
+ $(support_includes)
endif
if TEST_spfatal02
sp_tests += spfatal02
sp_screens += spfatal02/spfatal02.scn
sp_docs += spfatal02/spfatal02.doc
-spfatal02_SOURCES = spfatal_support/init.c \
- spfatal02/testcase.h
+spfatal02_SOURCES = spfatal02/init.c
spfatal02_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal02) \
- $(support_includes) -I$(top_srcdir)/spfatal02
+ $(support_includes)
endif
if TEST_spfatal03
sp_tests += spfatal03
sp_screens += spfatal03/spfatal03.scn
sp_docs += spfatal03/spfatal03.doc
-spfatal03_SOURCES = spfatal_support/init.c \
- spfatal03/testcase.h
+spfatal03_SOURCES = spfatal03/init.c
spfatal03_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal03) \
- $(support_includes) -I$(top_srcdir)/spfatal03
+ $(support_includes)
endif
if TEST_spfatal04
sp_tests += spfatal04
sp_screens += spfatal04/spfatal04.scn
sp_docs += spfatal04/spfatal04.doc
-spfatal04_SOURCES = spfatal_support/init.c \
- spfatal04/testcase.h
+spfatal04_SOURCES = spfatal04/init.c
spfatal04_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal04) \
- $(support_includes) -I$(top_srcdir)/spfatal04
+ $(support_includes)
endif
if TEST_spfatal05
sp_tests += spfatal05
sp_screens += spfatal05/spfatal05.scn
sp_docs += spfatal05/spfatal05.doc
-spfatal05_SOURCES = spfatal_support/init.c \
- spfatal05/testcase.h
+spfatal05_SOURCES = spfatal05/init.c
spfatal05_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal05) \
- $(support_includes) -I$(top_srcdir)/spfatal05
+ $(support_includes)
endif
if TEST_spfatal06
sp_tests += spfatal06
sp_screens += spfatal06/spfatal06.scn
sp_docs += spfatal06/spfatal06.doc
-spfatal06_SOURCES = spfatal_support/init.c \
- spfatal06/testcase.h
+spfatal06_SOURCES = spfatal06/init.c
spfatal06_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal06) \
- $(support_includes) -I$(top_srcdir)/spfatal06
+ $(support_includes)
endif
if TEST_spfatal08
sp_tests += spfatal08
sp_screens += spfatal08/spfatal08.scn
sp_docs += spfatal08/spfatal08.doc
-spfatal08_SOURCES = spfatal_support/init.c \
- spfatal08/testcase.h
+spfatal08_SOURCES = spfatal08/init.c
spfatal08_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal08) \
- $(support_includes) -I$(top_srcdir)/spfatal08
+ $(support_includes)
endif
if TEST_spfatal09
sp_tests += spfatal09
sp_screens += spfatal09/spfatal09.scn
sp_docs += spfatal09/spfatal09.doc
-spfatal09_SOURCES = spfatal_support/init.c \
- spfatal09/testcase.h
+spfatal09_SOURCES = spfatal09/init.c
spfatal09_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal09) \
- $(support_includes) -I$(top_srcdir)/spfatal09
+ $(support_includes)
endif
if TEST_spfatal10
sp_tests += spfatal10
sp_screens += spfatal10/spfatal10.scn
sp_docs += spfatal10/spfatal10.doc
-spfatal10_SOURCES = spfatal_support/init.c \
- spfatal10/testcase.h
+spfatal10_SOURCES = spfatal10/init.c
spfatal10_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal10) \
- $(support_includes) -I$(top_srcdir)/spfatal10
+ $(support_includes)
endif
if TEST_spfatal11
sp_tests += spfatal11
sp_screens += spfatal11/spfatal11.scn
sp_docs += spfatal11/spfatal11.doc
-spfatal11_SOURCES = spfatal_support/init.c \
- spfatal11/testcase.h
+spfatal11_SOURCES = spfatal11/init.c
spfatal11_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal11) \
- $(support_includes) -I$(top_srcdir)/spfatal11
+ $(support_includes)
endif
if TEST_spfatal12
sp_tests += spfatal12
sp_screens += spfatal12/spfatal12.scn
sp_docs += spfatal12/spfatal12.doc
-spfatal12_SOURCES = spfatal_support/init.c \
- spfatal12/testcase.h
+spfatal12_SOURCES = spfatal12/init.c
spfatal12_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal12) \
- $(support_includes) -I$(top_srcdir)/spfatal12
+ $(support_includes)
endif
if TEST_spfatal14
sp_tests += spfatal14
sp_screens += spfatal14/spfatal14.scn
sp_docs += spfatal14/spfatal14.doc
-spfatal14_SOURCES = spfatal_support/init.c \
- spfatal14/testcase.h
+spfatal14_SOURCES = spfatal14/init.c
spfatal14_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal14) \
- $(support_includes) -I$(top_srcdir)/spfatal14
+ $(support_includes)
endif
if TEST_spfatal15
sp_tests += spfatal15
sp_screens += spfatal15/spfatal15.scn
sp_docs += spfatal15/spfatal15.doc
-spfatal15_SOURCES = spfatal_support/init.c \
- spfatal15/testcase.h
+spfatal15_SOURCES = spfatal15/init.c
spfatal15_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal15) \
- $(support_includes) -I$(top_srcdir)/spfatal15
+ $(support_includes)
endif
if TEST_spfatal24
sp_tests += spfatal24
sp_screens += spfatal24/spfatal24.scn
sp_docs += spfatal24/spfatal24.doc
-spfatal24_SOURCES = spfatal_support/init.c \
- spfatal24/testcase.h
+spfatal24_SOURCES = spfatal24/init.c
spfatal24_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal24) \
- $(support_includes) -I$(top_srcdir)/spfatal24
+ $(support_includes)
endif
if TEST_spfatal25
sp_tests += spfatal25
sp_screens += spfatal25/spfatal25.scn
sp_docs += spfatal25/spfatal25.doc
-spfatal25_SOURCES = spfatal_support/init.c \
- spfatal25/testcase.h
+spfatal25_SOURCES = spfatal25/init.c
spfatal25_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal25) \
- $(support_includes) -I$(top_srcdir)/spfatal25
+ $(support_includes)
endif
if TEST_spfatal26
@@ -1049,30 +1034,27 @@ if TEST_spfatal27
sp_tests += spfatal27
sp_screens += spfatal27/spfatal27.scn
sp_docs += spfatal27/spfatal27.doc
-spfatal27_SOURCES = spfatal_support/init.c \
- spfatal27/testcase.h
+spfatal27_SOURCES = spfatal27/init.c
spfatal27_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal27) \
- $(support_includes) -I$(top_srcdir)/spfatal27
+ $(support_includes)
endif
if TEST_spfatal28
sp_tests += spfatal28
sp_screens += spfatal28/spfatal28.scn
sp_docs += spfatal28/spfatal28.doc
-spfatal28_SOURCES = spfatal_support/init.c \
- spfatal28/testcase.h
+spfatal28_SOURCES = spfatal28/init.c
spfatal28_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal28) \
- $(support_includes) -I$(top_srcdir)/spfatal28
+ $(support_includes)
endif
if TEST_spfatal29
sp_tests += spfatal29
sp_screens += spfatal29/spfatal29.scn
sp_docs += spfatal29/spfatal29.doc
-spfatal29_SOURCES = spfatal_support/init.c \
- spfatal29/testcase.h
+spfatal29_SOURCES = spfatal29/init.c
spfatal29_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal29) \
- $(support_includes) -I$(top_srcdir)/spfatal29
+ $(support_includes)
endif
if TEST_spfatal30
@@ -1097,10 +1079,9 @@ if TEST_spfatal32
sp_tests += spfatal32
sp_screens += spfatal32/spfatal32.scn
sp_docs += spfatal32/spfatal32.doc
-spfatal32_SOURCES = spfatal_support/init.c \
- spfatal32/testcase.h
+spfatal32_SOURCES = spfatal32/init.c
spfatal32_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_spfatal32) \
- $(support_includes) -I$(top_srcdir)/spfatal32
+ $(support_includes)
endif
if TEST_spfifo01