summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/pppd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-13 06:46:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-13 06:46:05 +0000
commita6b588d649d6fcc933aa356f3c36a1d2f6391976 (patch)
tree70ac33505ec6effe85d5875648a8c5a9c8479469 /testsuites/samples/pppd/Makefile.am
parent2005-11-13 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-a6b588d649d6fcc933aa356f3c36a1d2f6391976.tar.bz2
Convert to using *_PROGRAMS.
Diffstat (limited to 'testsuites/samples/pppd/Makefile.am')
-rw-r--r--testsuites/samples/pppd/Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/testsuites/samples/pppd/Makefile.am b/testsuites/samples/pppd/Makefile.am
index d7b37fd9e7..9aec709f6c 100644
--- a/testsuites/samples/pppd/Makefile.am
+++ b/testsuites/samples/pppd/Makefile.am
@@ -2,28 +2,24 @@
## $Id$
##
-PGM = ${ARCH}/pppd.exe
-
MANAGERS = io event semaphore
-noinst_LIBRARIES = lib.a
-lib_a_SOURCES = init.c pppdapp.c netconfig.h system.h
-
-OBJS = $(lib_a_OBJECTS)
-
-testsdir = $(libdir)/tests
+rtems_tests_PROGRAMS = pppd.exe
+pppd_exe_SOURCES = init.c pppdapp.c netconfig.h system.h
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-$(PGM): ${ARCH}/$(dirstamp)
+pppd_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
-LD_LIBS = -lpppd
+pppd_exe_LDLIBS = -lpppd
-tests_SCRIPTS = $(PGM)
+LINK_OBJS = $(pppd_exe_OBJECTS) $(pppd_exe_LDADD)
+LINK_LIBS = $(pppd_exe_LDLIBS)
-$(PGM): $(OBJS) $(LINK_FILES)
+pppd.exe$(EXEEXT): $(pppd_exe_OBJECTS) $(pppd_exe_DEPENDENCIES)
+ @rm -f pppd.exe$(EXEEXT)
$(make-exe)
include $(top_srcdir)/../automake/local.am