summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/fileio/Makefile.am
diff options
context:
space:
mode:
authorJennifer Averett <Jennifer.Averett@OARcorp.com>2003-08-06 19:20:52 +0000
committerJennifer Averett <Jennifer.Averett@OARcorp.com>2003-08-06 19:20:52 +0000
commitac0a2afe7392f4cb790fb67702da0f3b02cde556 (patch)
treeaa4032e7e82906056407ff04b110602c0ea378c0 /testsuites/samples/fileio/Makefile.am
parent2003-08-06 Thomas Doerfler<Thomas.Doerfler@imd-systems.de> (diff)
downloadrtems-ac0a2afe7392f4cb790fb67702da0f3b02cde556.tar.bz2
2003-08-06 Thomas Doerfler<Thomas.Doerfler@imd-systems.de>
PR 369/filesystem * Makefile.am, configure.ac: sample application to show the use of the DOSFS functions * fileio/Makefile.am, fileio/fileio.doc, fileio/init.c, fileio/system.h: New files.
Diffstat (limited to 'testsuites/samples/fileio/Makefile.am')
-rw-r--r--testsuites/samples/fileio/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/testsuites/samples/fileio/Makefile.am b/testsuites/samples/fileio/Makefile.am
new file mode 100644
index 0000000000..4ea7b3a71d
--- /dev/null
+++ b/testsuites/samples/fileio/Makefile.am
@@ -0,0 +1,42 @@
+##
+## Makefile.am,v 1.9 2002/08/11 05:18:59 ralf Exp
+##
+
+
+SAMPLE = fileio
+PGM = ${ARCH}/$(SAMPLE).exe
+
+MANAGERS = io message semaphore
+
+C_FILES = init.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+
+H_FILES = system.h
+noinst_HEADERS = $(H_FILES)
+
+DOCTYPES = doc scn
+DOCS = $(DOCTYPES:%=$(SAMPLE).%)
+
+SRCS = $(DOCS) $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../../../automake/leaf.am
+include $(top_srcdir)/sample.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+all-local: ${ARCH} $(TMPINSTALL_FILES)
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-exe)
+
+EXTRA_DIST = $(C_FILES) $(DOCS)
+
+include $(top_srcdir)/../../../../automake/local.am
+