summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-27 23:30:07 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-27 23:30:07 +0000
commit4691b48d1dfcdb04737fb005de78e06eee107774 (patch)
treee6c45fb830f3fa4e546aeb2a856993e20656ebb7 /testsuites/samples/configure.ac
parent2003-01-27 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-4691b48d1dfcdb04737fb005de78e06eee107774.tar.bz2
2003-01-27 Joel Sherrill <joel@OARcorp.com>
* Makefile.am, configure.ac: Added new test loopback which shows how to use the loopback interface. Thank you Eric Norum for a portable target independent test which exercises the TCP/IP. This should prevent massive failures in the TCP/IP stack from reaching the street. * loopback/.cvsignore, loopback/Makefile.am, loopback/README, loopback/init.c, loopback/loopback.scn: New files.
Diffstat (limited to 'testsuites/samples/configure.ac')
-rw-r--r--testsuites/samples/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/testsuites/samples/configure.ac b/testsuites/samples/configure.ac
index d5868df067..33319e5ed1 100644
--- a/testsuites/samples/configure.ac
+++ b/testsuites/samples/configure.ac
@@ -32,7 +32,9 @@ RTEMS_CANONICALIZE_TOOLS
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
RTEMS_CHECK_CXX(RTEMS_BSP)
+RTEMS_CHECK_NETWORKING
+AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
AM_CONDITIONAL(HAS_CXX,test "$HAS_CPLUSPLUS" = "yes")
AM_CONDITIONAL(HAS_MP,test "$HAS_MP" = "yes")
@@ -40,6 +42,7 @@ AM_CONDITIONAL(HAS_MP,test "$HAS_MP" = "yes")
AC_CONFIG_FILES([Makefile
base_sp/Makefile
hello/Makefile
+loopback/Makefile
minimum/Makefile
paranoia/Makefile
ticker/Makefile