summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2017-04-04 08:11:24 +1000
committerChris Johns <chrisj@rtems.org>2017-04-04 08:24:22 +1000
commit258bda306ba25741624488d24a2785c055a9fab0 (patch)
tree66301d9e50cf6dbc08539b441cab8b41ffe2f895 /testsuites/samples/configure.ac
parentbsp/qoriq: Fix L1 cache flush (diff)
downloadrtems-258bda306ba25741624488d24a2785c055a9fab0.tar.bz2
testsuite: Add a common test configuration. Fix configure.ac and Makefile.am errors.
- Add a top level test configuration file for test states that are common to all BSPs. This saves adding a test configuration (tcfg) file for every BSP. - Add the test states 'user-input' and 'benchmark'. This lets 'rtems-test' stop the test rather than waiting for a timeout or letting a benchmark run without the user asking for it to run. - Implement rtems-test-check in Python to make it faster. The shell script had grown to a point it was noticably slowing the build down. - Fix the configure.ac and Makefile.am files for a number of the test directories. The files are difficiult to keep in sync with the number of tests and mistakes can happen such as tests being left out of the build. The test fsrofs01 is an example. Also a there was a mix of SUBDIRS and _SUBDIRS being used and only _SUBDIRS should be used. - Fix the test fsrofs01 so it compiles. Closes #2963.
Diffstat (limited to 'testsuites/samples/configure.ac')
-rw-r--r--testsuites/samples/configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/testsuites/samples/configure.ac b/testsuites/samples/configure.ac
index 91a36612df..ffe1bad2c2 100644
--- a/testsuites/samples/configure.ac
+++ b/testsuites/samples/configure.ac
@@ -37,7 +37,7 @@ AS_IF([test $HAS_CPLUSPLUS = yes],[
[rtems_cv_HAVE_IOSTREAM_STD_NAMESPACE],
[AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
- [[#include <iostream>]],
+ [[#include <iostream>]],
[[std::cout << "hello" << std::endl;]])
],
[rtems_cv_HAVE_IOSTREAM_STD_NAMESPACE=yes],
@@ -60,21 +60,21 @@ AC_CHECK_SIZEOF([time_t])
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
+base_mp/Makefile
+base_mp/node1/Makefile
+base_mp/node2/Makefile
base_sp/Makefile
+capture/Makefile
+cdtest/Makefile
+fileio/Makefile
hello/Makefile
+iostream/Makefile
loopback/Makefile
minimum/Makefile
-fileio/Makefile
nsecs/Makefile
paranoia/Makefile
+pppd/Makefile
ticker/Makefile
unlimited/Makefile
-base_mp/Makefile
-base_mp/node1/Makefile
-base_mp/node2/Makefile
-iostream/Makefile
-cdtest/Makefile
-pppd/Makefile
-capture/Makefile
])
AC_OUTPUT