summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-27 23:30:07 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2003-01-27 23:30:07 +0000
commit4691b48d1dfcdb04737fb005de78e06eee107774 (patch)
treee6c45fb830f3fa4e546aeb2a856993e20656ebb7 /testsuites/samples/Makefile.am
parent2003-01-27 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-4691b48d1dfcdb04737fb005de78e06eee107774.tar.bz2
2003-01-27 Joel Sherrill <joel@OARcorp.com>
* Makefile.am, configure.ac: Added new test loopback which shows how to use the loopback interface. Thank you Eric Norum for a portable target independent test which exercises the TCP/IP. This should prevent massive failures in the TCP/IP stack from reaching the street. * loopback/.cvsignore, loopback/Makefile.am, loopback/README, loopback/init.c, loopback/loopback.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/samples/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/testsuites/samples/Makefile.am b/testsuites/samples/Makefile.am
index c94f2369ee..d10b81b308 100644
--- a/testsuites/samples/Makefile.am
+++ b/testsuites/samples/Makefile.am
@@ -11,8 +11,11 @@ MP_TESTS = base_mp
FP_TESTS = paranoia
+## loopback tests a network loopback interface
+NET_TESTS = loopback
+
SUBDIRS = hello ticker base_sp unlimited minimum $(MP_TESTS) \
- $(CPLUSPLUS_TESTS) $(FP_TESTS)
+ $(CPLUSPLUS_TESTS) $(FP_TESTS) $(NET_TESTS)
AUTOMAKE_FILES = sample.am