summaryrefslogtreecommitdiffstats
path: root/testsuites/samples/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2014-05-05 08:12:52 +1000
committerChris Johns <chrisj@rtems.org>2014-05-05 10:24:41 +1000
commit1461b648b7fc53b903c07da49df1bf24d96e8dca (patch)
treefd5016bd1a13b7d19cf3cbb93a6c084a69e92835 /testsuites/samples/Makefile.am
parentlibchip: Add asserts to dwmac driver (diff)
downloadrtems-1461b648b7fc53b903c07da49df1bf24d96e8dca.tar.bz2
testsuite: Add a per BSP test check for tests not to build.
Provide a file per BSP to list tests that do not build for a BSP. This change removes the BSP_SMALL_MEMORY hack from the code. That hack was a mistake. Provide configuration files for each BSP with tests that cannot build.
Diffstat (limited to 'testsuites/samples/Makefile.am')
-rw-r--r--testsuites/samples/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/testsuites/samples/Makefile.am b/testsuites/samples/Makefile.am
index d0826b89a1..08455d3742 100644
--- a/testsuites/samples/Makefile.am
+++ b/testsuites/samples/Makefile.am
@@ -1,25 +1,25 @@
ACLOCAL_AMFLAGS = -I ../aclocal
-SUBDIRS = hello capture ticker base_sp unlimited minimum fileio
+_SUBDIRS = hello capture ticker base_sp unlimited minimum fileio
if MPTESTS
## base_mp is a sample multiprocessing test
-SUBDIRS += base_mp
+_SUBDIRS += base_mp
endif
-SUBDIRS += paranoia
+_SUBDIRS += paranoia
-SUBDIRS += nsecs
+_SUBDIRS += nsecs
if CXXTESTS
-SUBDIRS += iostream cdtest
+_SUBDIRS += iostream cdtest
endif
if NETTESTS
## loopback tests a network loopback interface
-SUBDIRS += loopback
-SUBDIRS += pppd
+_SUBDIRS += loopback
+_SUBDIRS += pppd
endif
-include $(top_srcdir)/../automake/subdirs.am
+include $(top_srcdir)/../automake/test-subdirs.am
include $(top_srcdir)/../automake/local.am