summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtmtests/psxtmrwlock01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2011-08-02 13:23:33 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2011-08-02 13:23:33 +0000
commit8fffe77b52c2a32276fe861338e6bebd45595b99 (patch)
tree6778ebf44654a25bc1cc78532fd310526be1b8fc /testsuites/psxtmtests/psxtmrwlock01/Makefile.am
parentRegenerate. (diff)
downloadrtems-8fffe77b52c2a32276fe861338e6bebd45595b99.tar.bz2
2011-08-02 Ricardo Aguirre <el.mastin@ymail.com>
PR 1874/tests * Makefile.am, configure.ac, psxtmtests_plan.csv: Add benchmark of multiple pthread_rwlock operations that can be done as single shot times. * psxtmrwlock01/.cvsignore, psxtmrwlock01/Makefile.am, psxtmrwlock01/init.c, psxtmrwlock01/psxtmrwlock01.doc: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/psxtmtests/psxtmrwlock01/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/testsuites/psxtmtests/psxtmrwlock01/Makefile.am b/testsuites/psxtmtests/psxtmrwlock01/Makefile.am
new file mode 100644
index 0000000000..aad366917f
--- /dev/null
+++ b/testsuites/psxtmtests/psxtmrwlock01/Makefile.am
@@ -0,0 +1,30 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxtmrwlock01
+psxtmrwlock01_SOURCES = init.c ../../tmtests/include/timesys.h \
+ ../../support/src/tmtests_empty_function.c \
+ ../../support/src/tmtests_support.c
+
+dist_rtems_tests_DATA = psxtmrwlock01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+OPERATION_COUNT = @OPERATION_COUNT@
+AM_CPPFLAGS += -I$(top_srcdir)/../tmtests/include
+AM_CPPFLAGS += -DOPERATION_COUNT=$(OPERATION_COUNT)
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxtmrwlock01_OBJECTS) $(psxtmrwlock01_LDADD)
+LINK_LIBS = $(psxtmrwlock01_LDLIBS)
+
+psxtmrwlock01$(EXEEXT): $(psxtmrwlock01_OBJECTS) $(psxtmrwlock01_DEPENDENCIES)
+ @rm -f psxtmrwlock01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am