summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxtimer/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-11 08:14:41 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-11 08:14:41 +0000
commit197c9135e25a330af13a4561daf6099d2bd91079 (patch)
tree8b36527f09524e85375ec0955f598b4e3f71196f /testsuites/psxtests/psxtimer/Makefile.am
parent2005-11-11 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-197c9135e25a330af13a4561daf6099d2bd91079.tar.bz2
Expand psxtests.am.
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/psxtimer/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/testsuites/psxtests/psxtimer/Makefile.am b/testsuites/psxtests/psxtimer/Makefile.am
index 7bef1b7a63..7e20fa8ad1 100644
--- a/testsuites/psxtests/psxtimer/Makefile.am
+++ b/testsuites/psxtests/psxtimer/Makefile.am
@@ -19,7 +19,27 @@ PGM = ${ARCH}/$(TEST).exe
include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
include $(top_srcdir)/../automake/compile.am
include $(top_srcdir)/../automake/leaf.am
-include $(top_srcdir)/psxtests.am
+
+project_bspdir=$(PROJECT_ROOT)
+
+$(project_bspdir)/tests/$(dirstamp):
+ @$(mkdir_p) $(project_bspdir)/tests
+ @: > $(project_bspdir)/tests/$(dirstamp)
+
+$(project_bspdir)/tests/$(TEST).exe: $(PGM) $(project_bspdir)/tests/$(dirstamp)
+ $(INSTALL_PROGRAM) $< $@
+
+$(project_bspdir)/tests/screens/psxtests/$(dirstamp):
+ @$(mkdir_p) $(project_bspdir)/tests/screens/psxtests
+ @: > $(project_bspdir)/tests/screens/psxtests/$(dirstamp)
+
+$(project_bspdir)/tests/screens/psxtests/$(TEST).scn: $(TEST).scn $(project_bspdir)/tests/screens/psxtests/$(dirstamp)
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES = $(project_bspdir)/tests/$(TEST).exe
+TMPINSTALL_FILES += $(project_bspdir)/tests/screens/psxtests/$(TEST).scn
+
+$(PGM): ${ARCH}/$(dirstamp)
#
# (OPTIONAL) Add local stuff here using +=