summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxspin02/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2016-11-16 14:50:09 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2016-11-23 12:52:06 +0100
commitc42be504c92d76d2e06d0fc8ebd05fc913376d2d (patch)
tree259f8a712a6139f427888647955bc3c95480877e /testsuites/psxtests/psxspin02/Makefile.am
parentscore: Add RTEMS_ALIAS() (diff)
downloadrtems-c42be504c92d76d2e06d0fc8ebd05fc913376d2d.tar.bz2
posix: Add self-contained pthread spinlock
Turn pthread_spinlock_t into a self-contained object. On uni-processor configurations, interrupts are disabled in the lock/trylock operations and the previous interrupt status is restored in the corresponding unlock operations. On SMP configurations, a ticket lock is a acquired and released in addition. The self-contained pthread_spinlock_t object is defined by Newlib in <sys/_pthreadtypes.h>. typedef struct { struct _Ticket_lock_Control _lock; __uint32_t _interrupt_state; } pthread_spinlock_t; This implementation is simple and efficient. However, this test case of the Linux Test Project would fail due to call of printf() and sleep() during spin lock ownership: https://github.com/linux-test-project/ltp/blob/master/testcases/open_posix_testsuite/conformance/interfaces/pthread_spin_lock/1-2.c There is only limited support for profiling on SMP configurations. Delete CORE spinlock implementation. Update #2674.
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/psxspin02/Makefile.am24
1 files changed, 0 insertions, 24 deletions
diff --git a/testsuites/psxtests/psxspin02/Makefile.am b/testsuites/psxtests/psxspin02/Makefile.am
deleted file mode 100644
index ad56e2ae28..0000000000
--- a/testsuites/psxtests/psxspin02/Makefile.am
+++ /dev/null
@@ -1,24 +0,0 @@
-
-rtems_tests_PROGRAMS = psxspin02
-psxspin02_SOURCES = main.c test.c ../include/pmacros.h
-
-dist_rtems_tests_DATA = psxspin02.scn
-dist_rtems_tests_DATA += psxspin02.doc
-
-include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
-include $(top_srcdir)/../automake/compile.am
-include $(top_srcdir)/../automake/leaf.am
-
-
-AM_CPPFLAGS += -I$(top_srcdir)/include
-AM_CPPFLAGS += -I$(top_srcdir)/../support/include
-
-LINK_OBJS = $(psxspin02_OBJECTS)
-LINK_LIBS = $(psxspin02_LDLIBS)
-
-psxspin02$(EXEEXT): $(psxspin02_OBJECTS) \
- $(psxspin02_DEPENDENCIES)
- @rm -f psxspin02$(EXEEXT)
- $(make-exe)
-
-include $(top_srcdir)/../automake/local.am