summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxsignal06/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-10-21 22:05:17 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-10-21 22:05:17 +0000
commit4fcd106dd4e09e4142ee0bc9eef0998215a114f1 (patch)
treed307e639b9b3855f2c416a8891f5d0b83d4aaf99 /testsuites/psxtests/psxsignal06/Makefile.am
parent2010-10-21 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-4fcd106dd4e09e4142ee0bc9eef0998215a114f1.tar.bz2
2010-10-21 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: New test to ensure pthread_cond_wait() and sleep() (e.g. interruptible blocking and sleeping) are interruptible by signal. * psxsignal06/.cvsignore, psxsignal06/Makefile.am, psxsignal06/init.c, psxsignal06/psxsignal06.doc, psxsignal06/psxsignal06.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/psxsignal06/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxsignal06/Makefile.am b/testsuites/psxtests/psxsignal06/Makefile.am
new file mode 100644
index 0000000000..7988ebbde4
--- /dev/null
+++ b/testsuites/psxtests/psxsignal06/Makefile.am
@@ -0,0 +1,25 @@
+##
+## $Id$
+##
+
+rtems_tests_PROGRAMS = psxsignal06
+psxsignal06_SOURCES = init.c
+
+dist_rtems_tests_DATA = psxsignal06.scn
+dist_rtems_tests_DATA += psxsignal06.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxsignal06_OBJECTS) $(psxsignal06_LDADD)
+LINK_LIBS = $(psxsignal06_LDLIBS)
+
+psxsignal06$(EXEEXT): $(psxsignal06_OBJECTS) $(psxsignal06_DEPENDENCIES)
+ @rm -f psxsignal06$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am