summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxkey03/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-30 20:21:41 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-30 20:21:41 +0000
commit64bad68bc811039e246e0565ca7ddfc4ed5a9528 (patch)
tree98c691310e926f697b6ab1c112b6e9c09aae106f /testsuites/psxtests/psxkey03/Makefile.am
parent2009-07-30 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-64bad68bc811039e246e0565ca7ddfc4ed5a9528.tar.bz2
2009-07-30 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add new test to account for properly handling keys when a thread has non-NULL key value and key has NULL destructor and when a thread has NULL key value and key has destructor. * psxkey03/.cvsignore, psxkey03/Makefile.am, psxkey03/init.c, psxkey03/psxkey03.doc, psxkey03/psxkey03.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/psxkey03/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxkey03/Makefile.am b/testsuites/psxtests/psxkey03/Makefile.am
new file mode 100644
index 0000000000..6394317e17
--- /dev/null
+++ b/testsuites/psxtests/psxkey03/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxkey03
+psxkey03_SOURCES = init.c
+
+dist_rtems_tests_DATA = psxkey03.scn
+dist_rtems_tests_DATA += psxkey03.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxkey03_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxkey03_OBJECTS) $(psxkey03_LDADD)
+LINK_LIBS = $(psxkey03_LDLIBS)
+
+psxkey03$(EXEEXT): $(psxkey03_OBJECTS) $(psxkey03_DEPENDENCIES)
+ @rm -f psxkey03$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am