summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxkey02/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-30 18:48:56 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2009-07-30 18:48:56 +0000
commit3e5a9e5176f1e58d0e2622708796474d2552d625 (patch)
tree82bc03351f5f3b52d741bf28c0eae213b2bf93ef /testsuites/psxtests/psxkey02/Makefile.am
parentSpaces -> tabs. (diff)
downloadrtems-3e5a9e5176f1e58d0e2622708796474d2552d625.tar.bz2
2009-07-30 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: Add new test for exercising running out of memory while allocating the key pointers. * psxkey02/.cvsignore, psxkey02/Makefile.am, psxkey02/init.c, psxkey02/psxkey02.doc, psxkey02/psxkey02.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/psxkey02/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxkey02/Makefile.am b/testsuites/psxtests/psxkey02/Makefile.am
new file mode 100644
index 0000000000..e5dc34b7e4
--- /dev/null
+++ b/testsuites/psxtests/psxkey02/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxkey02
+psxkey02_SOURCES = init.c
+
+dist_rtems_tests_DATA = psxkey02.scn
+dist_rtems_tests_DATA += psxkey02.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxkey02_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxkey02_OBJECTS) $(psxkey02_LDADD)
+LINK_LIBS = $(psxkey02_LDLIBS)
+
+psxkey02$(EXEEXT): $(psxkey02_OBJECTS) $(psxkey02_DEPENDENCIES)
+ @rm -f psxkey02$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am