summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psximfs01/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-28 18:48:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-28 18:48:25 +0000
commit43efb633bafe8d413f9a0f76e140fde7d6d96311 (patch)
treea9bc294bee22d36dc65053add961a8c719ecace1 /testsuites/psxtests/psximfs01/Makefile.am
parent2010-06-28 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-43efb633bafe8d413f9a0f76e140fde7d6d96311.tar.bz2
2010-06-28 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac: Add test to exercise IMFS behaviour with files of maximum sizes. * psximfs01/.cvsignore, psximfs01/Makefile.am, psximfs01/init.c, psximfs01/psximfs01.doc, psximfs01/psximfs01.scn: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/psximfs01/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/testsuites/psxtests/psximfs01/Makefile.am b/testsuites/psxtests/psximfs01/Makefile.am
new file mode 100644
index 0000000000..d6b51337a9
--- /dev/null
+++ b/testsuites/psxtests/psximfs01/Makefile.am
@@ -0,0 +1,26 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psximfs01
+psximfs01_SOURCES = init.c
+
+dist_rtems_tests_DATA = psximfs01.scn
+dist_rtems_tests_DATA += psximfs01.doc
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psximfs01_OBJECTS) $(psximfs01_LDADD)
+LINK_LIBS = $(psximfs01_LDLIBS)
+
+psximfs01$(EXEEXT): $(psximfs01_OBJECTS) $(psximfs01_DEPENDENCIES)
+ @rm -f psximfs01$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am