summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/psxenosys/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-13 16:56:21 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-13 16:56:21 +0000
commit8728969392fb21acd6c4d5918a05894b87f323b6 (patch)
tree54baf3e23fc60f064fbd2573df24c637e5855640 /testsuites/psxtests/psxenosys/Makefile.am
parent2007-12-13 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-8728969392fb21acd6c4d5918a05894b87f323b6.tar.bz2
2007-12-13 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac: New test to cover all RTEMS POSIX functions that return ENOSYS. * psxenosys/.cvsignore, psxenosys/Makefile.am, psxenosys/init.c, psxenosys/psxenosys.scn, psxenosys/system.h: New files.
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/psxenosys/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/testsuites/psxtests/psxenosys/Makefile.am b/testsuites/psxtests/psxenosys/Makefile.am
new file mode 100644
index 0000000000..a3bccd7508
--- /dev/null
+++ b/testsuites/psxtests/psxenosys/Makefile.am
@@ -0,0 +1,28 @@
+##
+## $Id$
+##
+
+MANAGERS = all
+
+rtems_tests_PROGRAMS = psxenosys.exe
+psxenosys_exe_SOURCES = init.c system.h ../include/pmacros.h
+
+dist_rtems_tests_DATA = psxenosys.scn
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../automake/compile.am
+include $(top_srcdir)/../automake/leaf.am
+
+psxenosys_exe_LDADD = $(MANAGERS_NOT_WANTED:%=$(PROJECT_LIB)/no-%.rel)
+
+AM_CPPFLAGS += -I$(top_srcdir)/include
+AM_CPPFLAGS += -I$(top_srcdir)/../support/include
+
+LINK_OBJS = $(psxenosys_exe_OBJECTS) $(psxenosys_exe_LDADD)
+LINK_LIBS = $(psxenosys_exe_LDLIBS)
+
+psxenosys.exe$(EXEEXT): $(psxenosys_exe_OBJECTS) $(psxenosys_exe_DEPENDENCIES)
+ @rm -f psxenosys.exe$(EXEEXT)
+ $(make-exe)
+
+include $(top_srcdir)/../automake/local.am