summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2013-12-09 14:22:13 -0600
committerJoel Sherrill <joel.sherrill@oarcorp.com>2013-12-13 08:35:52 -0600
commit7318449947e9123136dcad7c01041aadd58bb5be (patch)
tree5cd82bd6912f8fba096142770ed787ab4cab1fc4 /testsuites/psxtests/configure.ac
parentsptests: refactored sp09/screen14.c into two new tests (diff)
downloadrtems-7318449947e9123136dcad7c01041aadd58bb5be.tar.bz2
psxtests/configure.ac: Probe for SMP affinity methods
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/testsuites/psxtests/configure.ac b/testsuites/psxtests/configure.ac
index 8e0a2384cd..16676a4610 100644
--- a/testsuites/psxtests/configure.ac
+++ b/testsuites/psxtests/configure.ac
@@ -48,6 +48,27 @@ AC_CHECK_DECLS([pthread_attr_getguardsize],[],[],[[#include <pthread.h>]])
# Added to pthreads after initial revision. May not be in toolset
AC_CHECK_DECLS([pthread_attr_setguardsize],[],[],[[#include <pthread.h>]])
+# Added to newlib pthreads for RTEMS SMP (np), may not be present
+AC_CHECK_DECLS([pthread_attr_setaffinity_np],[].[],,[[#include <pthread.h>]])
+
+# Added to newlib pthreads for RTEMS SMP (np), may not be present
+AC_CHECK_DECLS([pthread_attr_getaffinity_np],[].[],,[[#include <pthread.h>]])
+
+# Added to newlib pthreads for RTEMS SMP (np), may not be present
+AC_CHECK_DECLS([pthread_setaffinity_np],[].[],,[[#include <pthread.h>]])
+
+# Added to newlib pthreads for RTEMS SMP (np), may not be present
+AC_CHECK_DECLS([pthread_getaffinity_np],[].[],,[[#include <pthread.h>]])
+
+# Added to newlib pthreads for RTEMS (np), may not be present
+AC_CHECK_DECLS([pthread_getattr_np],[].[],,[[#include <pthread.h>]])
+
+# Added to newlib pthreads for RTEMS SMP (np), may not be present
+AC_CHECK_HEADERS([cpuset.h])
+
+# Mandated by POSIX, not declared in some versions of newlib.
+AC_CHECK_DECLS([getrusage],,,[#include sys/resource.h])
+
# Mandated by POSIX, not declared in some versions of newlib.
AC_CHECK_DECLS([getrusage],,,[#include sys/resource.h])