summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/configure.ac
diff options
context:
space:
mode:
authorVaibhav Gupta <vaibhavgupta40@gmail.com>2019-07-23 19:11:54 +0530
committerJoel Sherrill <joel@rtems.org>2019-07-30 10:18:09 -0500
commit57e0173584a914b1a92aa73deade6afb463186db (patch)
tree1fe51973e29e9447fd929c565b2288e5a12b18d8 /testsuites/psxtests/configure.ac
parentarm/raspberrypi: Fix linker map (diff)
downloadrtems-57e0173584a914b1a92aa73deade6afb463186db.tar.bz2
psxtests: Add ndbm test suite
Joel Sherrill <joel@rtems.org> modified the patch to add autoconf logic to avoid building this new test unless the tool chain include <ndbm.h>. The ensures that git bisect continues to work and that the addition of this test does not immediately force the entire community to update their tools.
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/testsuites/psxtests/configure.ac b/testsuites/psxtests/configure.ac
index 85559e4aa5..bb44bb8883 100644
--- a/testsuites/psxtests/configure.ac
+++ b/testsuites/psxtests/configure.ac
@@ -36,6 +36,9 @@ AM_CONDITIONAL([HAS_CPLUSPLUS],[test x"$HAS_CPLUSPLUS" = x"yes"])
RTEMS_CHECK_CPUOPTS([RTEMS_POSIX_API])
AM_CONDITIONAL(HAS_POSIX,test x"${rtems_cv_RTEMS_POSIX_API}" = x"yes")
+AC_CHECK_HEADER([ndbm.h]. [HAS_NDBM=yes], [HAS_NDBM=no])
+AM_CONDITIONAL(HAS_NDBM,test x"${ac_cv_header_ndbm_h__HAS_NDBM_yes}" = x"yes")
+
# BSP Test configuration
RTEMS_TEST_CHECK([psx01])
RTEMS_TEST_CHECK([psx02])
@@ -110,6 +113,7 @@ RTEMS_TEST_CHECK([psxmsgq02])
RTEMS_TEST_CHECK([psxmsgq03])
RTEMS_TEST_CHECK([psxmsgq04])
RTEMS_TEST_CHECK([psxmutexattr01])
+RTEMS_TEST_CHECK([psxndbm01])
RTEMS_TEST_CHECK([psxobj01])
RTEMS_TEST_CHECK([psxonce01])
RTEMS_TEST_CHECK([psxpasswd01])