summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorHimanshu40 <himanshuwindows8.1@gmail.com>2018-12-01 23:23:06 +0530
committerJoel Sherrill <joel@rtems.org>2018-12-01 12:04:18 -0600
commite3086c9c5af3c5d46da12b6e9796d2f209114bf8 (patch)
treef0b30d5ab78705604e0cd970ee95440ee2b9598c /testsuites/psxtests/Makefile.am
parentpowerpc/haleakala:Add per-section compilation and linking support (GCI 2018) (diff)
downloadrtems-e3086c9c5af3c5d46da12b6e9796d2f209114bf8.tar.bz2
psxhdrs: add POSIX API signature tests for strings.h file (GCI 2018)
Diffstat (limited to '')
-rw-r--r--testsuites/psxtests/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 553b259245..d40df4cf55 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1113,7 +1113,16 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/semaphore/sem_post.c \
psxhdrs/semaphore/sem_wait.c \
psxhdrs/semaphore/sem_trywait.c \
- psxhdrs/semaphore/sem_timedwait.c
+ psxhdrs/semaphore/sem_timedwait.c \
+ psxhdrs/strings/bcmp.c \
+ psxhdrs/strings/bcopy.c \
+ psxhdrs/strings/ffs.c \
+ psxhdrs/strings/index.c \
+ psxhdrs/strings/rindex.c \
+ psxhdrs/strings/strcasecmp.c \
+ psxhdrs/strings/strcasecmp_l.c \
+ psxhdrs/strings/strncasecmp.c \
+ psxhdrs/strings/strncasecmp_l.c
endif
rtems_tests_PROGRAMS = $(psx_tests)