summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorShashvat Jain <shashvatjain2002@gmail.com>2018-12-06 08:08:12 -0500
committerJoel Sherrill <joel@rtems.org>2018-12-06 09:51:56 -0600
commit9598f83e7b2f447814fafba91811423b6ad4b016 (patch)
treea9251921d98f07848e46d013787cc042643fac0a /testsuites/psxtests/Makefile.am
parentPOSIX Signature Test for fenv.h (GCI 2018) (diff)
downloadrtems-9598f83e7b2f447814fafba91811423b6ad4b016.tar.bz2
psxhdrs: Add POSIX Conformance Tests for math.h (GCI 2018)
Includes API tests for y0l, y1l, and ynl which are in glibc but not in POSIX or newlib. They are disabled until further investigation as to compatibility requirements are determined per the referenced ticket. Updates #3638.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rw-r--r--testsuites/psxtests/Makefile.am192
1 files changed, 192 insertions, 0 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 09d5875d42..d24466da43 100644
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -1095,6 +1095,195 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
psxhdrs/dirent/telldir.c \
psxhdrs/glob/glob.c \
psxhdrs/glob/globfree.c \
+ psxhdrs/math/acos.c \
+ psxhdrs/math/acosf.c \
+ psxhdrs/math/acosh.c \
+ psxhdrs/math/acoshf.c \
+ psxhdrs/math/acoshl.c \
+ psxhdrs/math/acosl.c \
+ psxhdrs/math/asin.c \
+ psxhdrs/math/asinf.c \
+ psxhdrs/math/asinh.c \
+ psxhdrs/math/asinhf.c \
+ psxhdrs/math/asinhl.c \
+ psxhdrs/math/asinl.c \
+ psxhdrs/math/atan2.c \
+ psxhdrs/math/atan2f.c \
+ psxhdrs/math/atan2l.c \
+ psxhdrs/math/atan.c \
+ psxhdrs/math/atanf.c \
+ psxhdrs/math/atanh.c \
+ psxhdrs/math/atanhf.c \
+ psxhdrs/math/atanhl.c \
+ psxhdrs/math/atanl.c \
+ psxhdrs/math/cbrt.c \
+ psxhdrs/math/cbrtf.c \
+ psxhdrs/math/cbrtl.c \
+ psxhdrs/math/ceil.c \
+ psxhdrs/math/ceilf.c \
+ psxhdrs/math/ceill.c \
+ psxhdrs/math/copysign.c \
+ psxhdrs/math/copysignf.c \
+ psxhdrs/math/copysignl.c \
+ psxhdrs/math/cos.c \
+ psxhdrs/math/cosf.c \
+ psxhdrs/math/cosh.c \
+ psxhdrs/math/coshf.c \
+ psxhdrs/math/coshl.c \
+ psxhdrs/math/cosl.c \
+ psxhdrs/math/erf.c \
+ psxhdrs/math/erfc.c \
+ psxhdrs/math/erfcf.c \
+ psxhdrs/math/erfcl.c \
+ psxhdrs/math/erff.c \
+ psxhdrs/math/erfl.c \
+ psxhdrs/math/exp2.c \
+ psxhdrs/math/exp2f.c \
+ psxhdrs/math/exp2l.c \
+ psxhdrs/math/exp.c \
+ psxhdrs/math/expf.c \
+ psxhdrs/math/expl.c \
+ psxhdrs/math/expm1.c \
+ psxhdrs/math/expm1f.c \
+ psxhdrs/math/expm1l.c \
+ psxhdrs/math/fabs.c \
+ psxhdrs/math/fabsf.c \
+ psxhdrs/math/fabsl.c \
+ psxhdrs/math/fdim.c \
+ psxhdrs/math/fdimf.c \
+ psxhdrs/math/fdiml.c \
+ psxhdrs/math/floor.c \
+ psxhdrs/math/floorf.c \
+ psxhdrs/math/floorl.c \
+ psxhdrs/math/fma.c \
+ psxhdrs/math/fmaf.c \
+ psxhdrs/math/fmal.c \
+ psxhdrs/math/fmax.c \
+ psxhdrs/math/fmaxf.c \
+ psxhdrs/math/fmaxl.c \
+ psxhdrs/math/fmin.c \
+ psxhdrs/math/fminf.c \
+ psxhdrs/math/fminl.c \
+ psxhdrs/math/fmod.c \
+ psxhdrs/math/fmodf.c \
+ psxhdrs/math/fmodl.c \
+ psxhdrs/math/fpclassify.c \
+ psxhdrs/math/frexp.c \
+ psxhdrs/math/frexpf.c \
+ psxhdrs/math/frexpl.c \
+ psxhdrs/math/hypot.c \
+ psxhdrs/math/hypotf.c \
+ psxhdrs/math/hypotl.c \
+ psxhdrs/math/ilogb.c \
+ psxhdrs/math/ilogbf.c \
+ psxhdrs/math/ilogbl.c \
+ psxhdrs/math/isfinite.c \
+ psxhdrs/math/isgreater.c \
+ psxhdrs/math/isgreaterequal.c \
+ psxhdrs/math/isinf.c \
+ psxhdrs/math/isless.c \
+ psxhdrs/math/islessequal.c \
+ psxhdrs/math/islessgreater.c \
+ psxhdrs/math/isnan.c \
+ psxhdrs/math/isnormal.c \
+ psxhdrs/math/isunordered.c \
+ psxhdrs/math/ldexp.c \
+ psxhdrs/math/ldexpf.c \
+ psxhdrs/math/ldexpl.c \
+ psxhdrs/math/lgamma.c \
+ psxhdrs/math/lgammaf.c \
+ psxhdrs/math/lgammal.c \
+ psxhdrs/math/llrint.c \
+ psxhdrs/math/llrintf.c \
+ psxhdrs/math/llrintl.c \
+ psxhdrs/math/llround.c \
+ psxhdrs/math/llroundf.c \
+ psxhdrs/math/llroundl.c \
+ psxhdrs/math/log10.c \
+ psxhdrs/math/log10f.c \
+ psxhdrs/math/log10l.c \
+ psxhdrs/math/log1p.c \
+ psxhdrs/math/log1pf.c \
+ psxhdrs/math/log1pl.c \
+ psxhdrs/math/log2.c \
+ psxhdrs/math/log2f.c \
+ psxhdrs/math/log2l.c \
+ psxhdrs/math/logb.c \
+ psxhdrs/math/logbf.c \
+ psxhdrs/math/logbl.c \
+ psxhdrs/math/log.c \
+ psxhdrs/math/logf.c \
+ psxhdrs/math/logl.c \
+ psxhdrs/math/lrint.c \
+ psxhdrs/math/lrintf.c \
+ psxhdrs/math/lrintl.c \
+ psxhdrs/math/lround.c \
+ psxhdrs/math/lroundf.c \
+ psxhdrs/math/lroundl.c \
+ psxhdrs/math/modf.c \
+ psxhdrs/math/modff.c \
+ psxhdrs/math/modfl.c \
+ psxhdrs/math/nan.c \
+ psxhdrs/math/nanf.c \
+ psxhdrs/math/nanl.c \
+ psxhdrs/math/nearbyint.c \
+ psxhdrs/math/nearbyintf.c \
+ psxhdrs/math/nearbyintl.c \
+ psxhdrs/math/nextafter.c \
+ psxhdrs/math/nextafterf.c \
+ psxhdrs/math/nextafterl.c \
+ psxhdrs/math/nexttoward.c \
+ psxhdrs/math/nexttowardf.c \
+ psxhdrs/math/nexttowardl.c \
+ psxhdrs/math/pow.c \
+ psxhdrs/math/powf.c \
+ psxhdrs/math/powl.c \
+ psxhdrs/math/remainder.c \
+ psxhdrs/math/remainderf.c \
+ psxhdrs/math/remainderl.c \
+ psxhdrs/math/remquo.c \
+ psxhdrs/math/remquof.c \
+ psxhdrs/math/remquol.c \
+ psxhdrs/math/rint.c \
+ psxhdrs/math/rintf.c \
+ psxhdrs/math/rintl.c \
+ psxhdrs/math/round.c \
+ psxhdrs/math/roundf.c \
+ psxhdrs/math/roundl.c \
+ psxhdrs/math/scalbln.c \
+ psxhdrs/math/scalblnf.c \
+ psxhdrs/math/scalblnl.c \
+ psxhdrs/math/scalbn.c \
+ psxhdrs/math/scalbnf.c \
+ psxhdrs/math/scalbnl.c \
+ psxhdrs/math/signbit.c \
+ psxhdrs/math/sin.c \
+ psxhdrs/math/sinf.c \
+ psxhdrs/math/sinh.c \
+ psxhdrs/math/sinhf.c \
+ psxhdrs/math/sinhl.c \
+ psxhdrs/math/sinl.c \
+ psxhdrs/math/sqrt.c \
+ psxhdrs/math/sqrtf.c \
+ psxhdrs/math/sqrtl.c \
+ psxhdrs/math/tan.c \
+ psxhdrs/math/tanf.c \
+ psxhdrs/math/tanh.c \
+ psxhdrs/math/tanhf.c \
+ psxhdrs/math/tanhl.c \
+ psxhdrs/math/tanl.c \
+ psxhdrs/math/tgamma.c \
+ psxhdrs/math/tgammaf.c \
+ psxhdrs/math/tgammal.c \
+ psxhdrs/math/trunc.c \
+ psxhdrs/math/truncf.c \
+ psxhdrs/math/truncl.c \
+ psxhdrs/math/y0.c \
+ psxhdrs/math/y0f.c \
+ psxhdrs/math/y1.c \
+ psxhdrs/math/y1f.c \
+ psxhdrs/math/yn.c \
+ psxhdrs/math/ynf.c \
psxhdrs/mqueue/mq_open.c \
psxhdrs/mqueue/mq_close.c \
psxhdrs/mqueue/mq_getattr.c \
@@ -1340,6 +1529,9 @@ lib_a_SOURCES = psxhdrs/devctl/posix_devctl.c \
## lib_a_SOURCES += psxhdrs/fenv/fesetround.c See ticket #2971
## lib_a_SOURCES += psxhdrs/fenv/fetestexcept.c See ticket #2971
## lib_a_SOURCES += psxhdrs/ftw/ftw.c See ticket #2970
+## lib_a_SOURCES += psxhdrs/math/y0l.c See ticket #3638
+## lib_a_SOURCES += psxhdrs/math/y1l.c See ticket #3638
+## lib_a_SOURCES += psxhdrs/math/ynl.c See ticket #3638
## lib_a_SOURCES += psxhdrs/ftw/nftw.c See ticket #2970
## lib_a_SOURCES += psxhdrs/stdio/getdelim.c See ticket #3633
## lib_a_SOURCES += psxhdrs/stdio/getline.c See ticket #3633