summaryrefslogtreecommitdiffstats
path: root/testsuites/psxtests/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2019-09-10 12:53:31 -0500
committerJoel Sherrill <joel@rtems.org>2019-09-24 16:27:57 -0500
commit8798372261ed1df999bc9f4f3f0be0a230480041 (patch)
tree0762d89609e1bb4717335838f56b254fdaaba2e9 /testsuites/psxtests/Makefile.am
parentrtems: Add rtems_interrupt_server_entry_move() (diff)
downloadrtems-8798372261ed1df999bc9f4f3f0be0a230480041.tar.bz2
Correct initial POSIX signals mask
+ Modify POSIX thread create extension to ensure expected initial signal mask is provided to system threads, initial tasks and threads, and inheritied by tasks and threads. + Adds psxsignal07 to verify functionality when using a POSIX Initialization thread and POSIX threads. + Adds psxsignal08 to verify functionality when using a Classic API Initialization task and Classic API tasks. Closes #3794.
Diffstat (limited to 'testsuites/psxtests/Makefile.am')
-rwxr-xr-xtestsuites/psxtests/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/testsuites/psxtests/Makefile.am b/testsuites/psxtests/Makefile.am
index 2ccb10a473..536b77f560 100755
--- a/testsuites/psxtests/Makefile.am
+++ b/testsuites/psxtests/Makefile.am
@@ -881,6 +881,28 @@ psxsignal06_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxsignal06) \
endif
endif
+if HAS_POSIX
+if TEST_psxsignal07
+psx_tests += psxsignal07
+psx_screens += psxsignal07/psxsignal07.scn
+psx_docs += psxsignal07/psxsignal07.doc
+psxsignal07_SOURCES = psxsignal07/main.c psxsignal07/rtems_config.c
+psxsignal07_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxsignal07) \
+ $(support_includes) -I$(top_srcdir)/include
+endif
+endif
+
+if HAS_POSIX
+if TEST_psxsignal08
+psx_tests += psxsignal08
+psx_screens += psxsignal08/psxsignal08.scn
+psx_docs += psxsignal08/psxsignal08.doc
+psxsignal08_SOURCES = psxsignal08/main.c psxsignal08/rtems_config.c
+psxsignal08_CPPFLAGS = $(AM_CPPFLAGS) $(TEST_FLAGS_psxsignal08) \
+ $(support_includes) -I$(top_srcdir)/include
+endif
+endif
+
if TEST_psxspin01
psx_tests += psxspin01
psx_screens += psxspin01/psxspin01.scn